package/most: disable parallel build
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 14 Apr 2019 10:00:26 +0000 (12:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Apr 2019 12:57:07 +0000 (14:57 +0200)
The hand-written Makefile is not parallel-build safe: the objs directory
is created in a separate rule, but the rules that create files in that
directory don't depend on it.

Although this relatively simple to fix, upstream clearly doesn't care
about parallel builds so it is likely to break again in the future.
Since most consists of just a dozen source files, just disable parallel
build.

Fixes:
http://autobuild.buildroot.net/results/c7540203a8eadad3f324f0d7e7fe66a526d4a2e9

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Cc: Sven Oliver Moll <buildroot@svol.li>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/most/most.mk

index d24e67f936f5e23f69c94b6577a7f64ea7fd2e0c..28d82cddf1f655ad890425828cae92ead10e1fd3 100644 (file)
@@ -11,6 +11,7 @@ MOST_LICENSE_FILES = COPYING COPYRIGHT
 MOST_DEPENDENCIES = slang
 
 MOST_CONF_OPTS = --with-slang=$(STAGING_DIR)/usr
+MOST_MAKE = $(MAKE1)
 
 define MOST_REMOVE_LOCAL_SLANG_CHECK
        $(SED) 's/ slangversion / /g' $(@D)/src/Makefile.in