Fix autotools configuration cache handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 28 Apr 2010 21:41:00 +0000 (23:41 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 22:00:09 +0000 (00:00 +0200)
It got broken by the introduction of the new autotools infrastructure
based on the generic infrastructure.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index 67cc88abe455cc07d975942ff2ed27ce395b6f3c..318bd714ae3c9ef63b1426944d2323a1683d3833 100644 (file)
@@ -93,7 +93,7 @@ define $(2)_CONFIGURE_CMDS
        $$(TARGET_CONFIGURE_ENV) \
        $$($$(PKG)_CONF_ENV) \
        ./configure \
-               $(if $(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/tgt-config.cache",) \
+               $$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/tgt-config.cache",) \
                --target=$$(GNU_TARGET_NAME) \
                --host=$$(GNU_TARGET_NAME) \
                --build=$$(GNU_HOST_NAME) \