boot/uboot: add support for i.MX28 SD format
authorVincent Stehlé <vincent.stehle@freescale.com>
Sun, 22 Mar 2015 13:25:14 +0000 (14:25 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 15:25:20 +0000 (17:25 +0200)
Allow to generate u-boot.sd, Freescale i.MX28 SB format with a header for
booting from an SD card.

U-boot includes an mxsboot tool to generate this format, starting from
v2011.12.

See u-boot doc/README.mxs (or doc/README.mx28_common before 2013.07).

[Arnout:
 - Wrap Config.in help text at 72 columns.
 - Remove v from U-Boot version specifier.
 - Refer to different README name before 2013.07.
 - Depend on host-elftosb
 - Add comment to clarify sb -> sd conversion.]

Signed-off-by: Vincent Stehlé <vincent.stehle@freescale.com>
Tested-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Reviewed-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 03e6acc02d5fe38ad0ce0ef4820d05d74232ace8..3f39ee8133d9d75eca16898b878d7d8840692a2e 100644 (file)
@@ -117,6 +117,18 @@ config BR2_TARGET_UBOOT_FORMAT_SB
        depends on BR2_arm
        bool "u-boot.sb"
 
+config BR2_TARGET_UBOOT_FORMAT_SD
+       depends on BR2_arm
+       bool "u-boot.sd"
+       help
+         This is Freescale i.MX28 SB format, with a header for booting
+         from an SD card.
+
+         U-boot includes an mxsboot tool to generate this format,
+         starting from 2011.12.
+
+         See doc/README.mxs (or doc/README.mx28_common before 2013.07)
+
 config BR2_TARGET_UBOOT_FORMAT_CUSTOM
        bool "Custom (specify below)"
        help
index a9ba0549a1cfb8ab9db2000e96700aed6448544f..630619a4f5137d9a7bf1c78db520df76ba465e33 100644 (file)
@@ -49,6 +49,11 @@ else ifeq ($(BR2_TARGET_UBOOT_FORMAT_SB),y)
 UBOOT_BIN = u-boot.sb
 UBOOT_MAKE_TARGET = $(UBOOT_BIN)
 UBOOT_DEPENDENCIES += host-elftosb
+else ifeq ($(BR2_TARGET_UBOOT_FORMAT_SD),y)
+# BootStream (.sb) is generated by U-Boot, we convert it to SD format
+UBOOT_BIN = u-boot.sd
+UBOOT_MAKE_TARGET = u-boot.sb
+UBOOT_DEPENDENCIES += host-elftosb
 else ifeq ($(BR2_TARGET_UBOOT_FORMAT_CUSTOM),y)
 UBOOT_BIN = $(call qstrip,$(BR2_TARGET_UBOOT_FORMAT_CUSTOM_NAME))
 else
@@ -116,6 +121,8 @@ define UBOOT_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS)        \
                $(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS)             \
                $(UBOOT_MAKE_TARGET)
+       $(if $(BR2_TARGET_UBOOT_FORMAT_SD),
+               $(@D)/tools/mxsboot sd $(@D)/u-boot.sb $(@D)/u-boot.sd)
 endef
 
 define UBOOT_BUILD_OMAP_IFT