- fix building mconf with curses flags
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 27 Jul 2007 12:37:30 +0000 (12:37 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 27 Jul 2007 12:37:30 +0000 (12:37 -0000)
- make sure to rm .config when the first 'make menuconfig' was interrupted and thus no .config.cmd was created.

Makefile
package/config/Makefile
package/config/Makefile.kconfig

index 61c776da916fc4989c9bbe3a3e59a3880cea086f..f069777975076d2432c85b3b1288cde1cb223dea 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -320,9 +320,11 @@ $(CONFIG)/mconf:
 
 menuconfig: $(CONFIG)/mconf
        @-mkdir -p $(CONFIG)/buildroot-config
-       @KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
+       @if ! KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
                KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
-               $(CONFIG)/mconf $(CONFIG_CONFIG_IN)
+               $(CONFIG)/mconf $(CONFIG_CONFIG_IN); then \
+               test -f .config.cmd || rm -f .config; \
+       fi
 
 config: $(CONFIG)/conf
        @-mkdir -p $(CONFIG)/buildroot-config
index 3b43849206f50c94be53b4b7c08f7d06115ccc27..f25b704e6aa06070b788cd81894621695a874790 100644 (file)
@@ -5,7 +5,7 @@ top_builddir=../../
 srctree := .
 
 include Makefile.kconfig
-HOSTCFLAGS+=-Dinline="" -include foo.h
+#HOSTCFLAGS+=-Dinline="" -include foo.h
 -include .depend
 .depend: $(wildcard *.h *.c)
        $(HOSTCC) $(HOST_EXTRACFLAGS) $(HOSTCFLAGS) -MM *.c > .depend 2>/dev/null || :
index 7e7e147875bf0d01b453a65f2b037dcae20ef345..016397f669eb6fffcbbad858932c2148b2c9d8bb 100644 (file)
@@ -120,6 +120,9 @@ hostprogs-y := conf qconf gconf kxgettext
 ifeq ($(MAKECMDGOALS),menuconfig)
        hostprogs-y += mconf
 endif
+ifeq ($(findstring mconf,$(MAKECMDGOALS)),mconf)
+       hostprogs-y += mconf
+endif
 
 ifeq ($(MAKECMDGOALS),xconfig)
        qconf-target := 1