packages/exim: enable parallel make
authorLuca Ceresoli <luca@lucaceresoli.net>
Mon, 20 Apr 2020 16:36:45 +0000 (18:36 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 20 Apr 2020 21:08:04 +0000 (23:08 +0200)
Parallel make used to be broken in exim, as reported in its docs. Now that
line has disappeared from the docs, and parallel make is actually working.

Tested with 'make exim-dirclean ; time make BR2_JLEVEL=999 exim': builds
still succeed and the build time decreases from 34 to 11 seconds on my
host.

Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net>
Cc: Bernd Kuhls <bernd.kuhls@t-online.de>
Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/exim/exim.mk

index 8d5b6e415b62aadd66340862e8155e71aabd5f6c..dc445c6d93c0087a14b0d7ffce11fc5c6fa66911 100644 (file)
@@ -120,16 +120,14 @@ endif
 
 # We need the host version of macro_predef during the build, before
 # building it we need to prepare the makefile.
-# "The -j (parallel) flag must not be used with make"
-# (http://www.exim.org/exim-html-current/doc/html/spec_html/ch04.html)
 define EXIM_BUILD_CMDS
-       $(TARGET_MAKE_ENV) build=br $(MAKE1) -C $(@D) makefile
-       $(HOST_MAKE_ENV) $(MAKE1) -C $(@D)/build-br macro_predef \
+       $(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) makefile
+       $(HOST_MAKE_ENV) $(MAKE) -C $(@D)/build-br macro_predef \
                CC=$(HOSTCC) \
                LNCC=$(HOSTCC) \
                CFLAGS="-std=c99 $(HOST_CFLAGS)" \
                LFLAGS="-fPIC $(HOST_LDFLAGS)"
-       $(TARGET_MAKE_ENV) build=br $(MAKE1) -C $(@D) $(EXIM_STATIC_FLAGS) \
+       $(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
                CFLAGS="-std=c99 $(TARGET_CFLAGS)"
 endef
 
@@ -137,7 +135,7 @@ endef
 # something when installing...
 define EXIM_INSTALL_TARGET_CMDS
        DESTDIR=$(TARGET_DIR) INSTALL_ARG="-no_chown -no_symlink" build=br \
-         $(MAKE1) -C $(@D) $(EXIM_STATIC_FLAGS) \
+         $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
                CFLAGS="-std=c99 $(TARGET_CFLAGS)" \
                install
        chmod u+s $(TARGET_DIR)/usr/sbin/exim