dbus: add host-dbus support
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Mar 2009 20:58:15 +0000 (20:58 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Mar 2009 20:58:15 +0000 (20:58 -0000)
package/dbus/dbus.mk

index 0cf77b6309674e9591937405a8f0ad68bb737f52..9d43ab2a481315f60725e6d10d367c7d67a002e3 100644 (file)
@@ -53,3 +53,54 @@ $(DBUS_HOOK_POST_INSTALL): $(DBUS_TARGET_INSTALL_TARGET)
        rm -rf $(TARGET_DIR)/usr/lib/dbus-1.0
        $(INSTALL) -m 0755 package/dbus/S30dbus $(TARGET_DIR)/etc/init.d
        touch $@
+
+# dbus for the host
+DBUS_HOST_DIR:=$(BUILD_DIR)/dbus-$(DBUS_VERSION)-host
+DBUS_HOST_BINARY:=$(HOST_DIR)/usr/bin/dbus-daemon
+
+$(DBUS_HOST_DIR)/.unpacked: $(DL_DIR)/$(DBUS_SOURCE)
+       mkdir -p $(@D)
+       $(INFLATE$(suffix $(DBUS_SOURCE))) $< | \
+               $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
+       touch $@
+
+$(DBUS_HOST_DIR)/.configured: $(DBUS_HOST_DIR)/.unpacked $(EXPAT_HOST_BINARY)
+       (cd $(@D); rm -rf config.cache; \
+               $(HOST_CONFIGURE_OPTS) \
+               CFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS)" \
+               $(@D)/configure \
+               --prefix=$(HOST_DIR)/usr \
+               --sysconfdir=$(HOST_DIR)/etc \
+               --with-dbus-user=dbus \
+               --disable-tests \
+               --disable-asserts \
+               --enable-abstract-sockets \
+               --disable-selinux \
+               --disable-xml-docs \
+               --disable-doxygen-docs \
+               --disable-static \
+               --enable-dnotify \
+               --without-x \
+               --with-xml=expat \
+       )
+       touch $@
+
+$(DBUS_HOST_DIR)/.compiled: $(DBUS_HOST_DIR)/.configured
+       $(MAKE) -C $(@D)
+       touch $@
+
+$(DBUS_HOST_BINARY): $(DBUS_HOST_DIR)/.compiled
+       $(MAKE) -C $(<D) install
+
+host-dbus: $(DBUS_HOST_BINARY)
+
+host-dbus-source: dbus-source
+
+host-dbus-clean:
+       rm -f $(addprefix $(DBUS_HOST_DIR)/,.unpacked .configured .compiled)
+       $(MAKE) -C $(DBUS_HOST_DIR) uninstall
+       $(MAKE) -C $(DBUS_HOST_DIR) clean
+
+host-dbus-dirclean:
+       rm -rf $(DBUS_HOST_DIR)