buildroot: add external-deps target
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 4 Mar 2008 12:19:16 +0000 (12:19 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 4 Mar 2008 12:19:16 +0000 (12:19 -0000)
Add external-deps target to show what external files are needed to recreate
the build.

Makefile
toolchain/wget-show-external-deps.sh [new file with mode: 0755]

index 5ebf75eaee7ee5848a6b27ea4a2db93ef07fcf72..96436ef51701127a3c9a4f839fe84d5a1540854b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -322,6 +322,10 @@ source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 _source-check:
        $(MAKE) SPIDER=--spider source
 
+external-deps:
+       @$(MAKE) -Bs BR2_WGET=$(TOPDIR)toolchain/wget-show-external-deps.sh \
+       source
+
 #############################################################
 #
 # Cleanup and misc junk
@@ -461,6 +465,7 @@ help:
        @echo 'Miscellaneous:'
        @echo '  source                 - download all sources needed for offline-build'
        @echo '  source-check           - check all packages for valid download URLs'
+       @echo '  external-deps          - list external packages used'
        @echo
        @echo 'See docs/README and docs/buildroot.html for further details'
        @echo
diff --git a/toolchain/wget-show-external-deps.sh b/toolchain/wget-show-external-deps.sh
new file mode 100755 (executable)
index 0000000..20071c0
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+#
+# replacement for wget (see BR2_WGET) which simply shows the file name to be
+# downloaded. Used by the external-deps make target.
+
+exec basename ${!#}
\ No newline at end of file