gdb: fix target gdb building from git
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Tue, 24 Feb 2015 09:03:20 +0000 (12:03 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 16 Mar 2015 21:10:23 +0000 (22:10 +0100)
Currently we only add "host-texinfo" dependency for host GDB built
from git sources. But in case of target gdb texinfo won't be built
and so gdb building will fail on attempt to build documentation.

Fix is trivial - add "host-texinfo" as a dependency for target gdb
in the sme way as we disable documentation building via both
GDB_CONF_ENV (for target) and HOST_GDB_CONF_ENV (host) GDB flavors.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Anton Kolesov <akolesov@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdb/gdb.mk

index 6a192fb9c5f8ecd8adc6f59f760c6730650b1d07..58f0631a01728ce11f82cd11a30e5f19cfa6081b 100644 (file)
@@ -151,6 +151,7 @@ else
 endif
 
 ifeq ($(GDB_FROM_GIT),y)
+GDB_DEPENDENCIES += host-texinfo
 HOST_GDB_DEPENDENCIES += host-texinfo
 else
 # don't generate documentation