core/download: do not hard-code the path to the package hash file
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 14 Oct 2018 12:25:43 +0000 (14:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 20 Oct 2018 18:04:06 +0000 (20:04 +0200)
Now that packges may have hashes for their downloaded files in a
versioned subdir or in the unversioned hash file, we can no longer
hard-code the path to the package hash file anymore.

Instead, we now make use of the per-package variable, that points to the
package hash file.

Note: of the packages for which we offer a version choice, almost none,
but some of the qt5 ones, have a per-version hash file, so we still use
the unversioned hash file for them. As for the few qt5 packages that do
have a per-version hash file for their licensing terms, they've already
been updated to duplicate their download hashes in both the unversioned
and per-version hash files. So, one way or the other, no hash check
would go missing with this change.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Cc: Baruch Siach <baruch@tkos.co.il>
Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pkg-download.mk

index bf93b9a08e2d991d951f6ef1cdcaea7b6ac9b825..73ea2a69f82989c5e96621fa4b977a6f300acf29 100644 (file)
@@ -97,7 +97,7 @@ define DOWNLOAD
                -d '$($(PKG)_DL_DIR)' \
                -D '$(DL_DIR)' \
                -f '$(notdir $(1))' \
-               -H '$(PKGDIR)/$($(PKG)_RAWNAME).hash' \
+               -H '$($(PKG)_HASH_FILE)' \
                -n '$($(PKG)_BASENAME_RAW)' \
                -N '$($(PKG)_RAWNAME)' \
                -o '$($(PKG)_DL_DIR)/$(notdir $(1))' \