package/busybox: invert dependency with e2fsprogs
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 Jul 2018 09:46:04 +0000 (11:46 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 8 Jul 2018 11:08:05 +0000 (13:08 +0200)
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/busybox/busybox.mk
package/e2fsprogs/e2fsprogs.mk

index a567f25231d7b28964cb1745ab6070db8688c3d5..166d18708117ed6efdd64a87739a3c430455f123 100644 (file)
@@ -22,6 +22,7 @@ BUSYBOX_LDFLAGS = \
 
 # Packages that provide commands that may also be busybox applets:
 BUSYBOX_DEPENDENCIES = \
+       $(if $(BR2_PACKAGE_E2FSPROGS),e2fsprogs) \
        $(if $(BR2_PACKAGE_FBSET),fbset) \
        $(if $(BR2_PACKAGE_GAWK),gawk) \
        $(if $(BR2_PACKAGE_GREP),grep) \
index 316546a8d7334179d8f61feed6a5af146769c29c..efc10d0e996b47ee0af4fead9501aee3cc3c35dc 100644 (file)
@@ -17,12 +17,6 @@ E2FSPROGS_INSTALL_STAGING = YES
 E2FSPROGS_DEPENDENCIES = host-pkgconf util-linux
 HOST_E2FSPROGS_DEPENDENCIES = host-pkgconf host-util-linux
 
-# If both e2fsprogs and busybox are selected, make certain e2fsprogs
-# wins the fight over who gets to have their utils actually installed
-ifeq ($(BR2_PACKAGE_BUSYBOX),y)
-E2FSPROGS_DEPENDENCIES += busybox
-endif
-
 # e4defrag doesn't build on older systems like RHEL5.x, and we don't
 # need it on the host anyway.
 # Disable fuse2fs as well to avoid carrying over deps, and it's unused
@@ -35,8 +29,8 @@ HOST_E2FSPROGS_CONF_OPTS = \
        --enable-symlink-install \
        --disable-testio-debug
 
-# Set the binary directories to "/bin" and "/sbin" to override programs
-# installed by busybox.
+# Set the binary directories to "/bin" and "/sbin", as busybox does,
+# so that we do not end up with two versions of e2fs tools.
 E2FSPROGS_CONF_OPTS = \
        --bindir=/bin \
        --sbindir=/sbin \