wvstreams: remove tcl dependency support
authorAndrew Ruder <andrew.ruder@elecsyscorp.com>
Thu, 14 Nov 2013 22:57:58 +0000 (16:57 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 Nov 2013 07:49:07 +0000 (08:49 +0100)
As far as I can tell enabling tcl support has no affect on the actual
library.  Furthermore, wvstreams has been checking for/linking against
tcl 8.3 which has never been supported in buildroot as far as I can tell
(8.4 added in 2005).  That being said there is clearly no reason to keep
this around.

Signed-off-by: Andrew Ruder <andrew.ruder@elecsyscorp.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/wvstreams/wvstreams.mk

index b4f7d8929707016fa6d8b20215db81c105448f2f..41155a740f18ff386ddbe5ce4a288a25d2a9e73f 100644 (file)
@@ -22,7 +22,8 @@ WVSTREAMS_CONF_OPT += \
        --with-openssl \
        --with-zlib \
        --without-pam \
-       --disable-warnings
+       --disable-warnings \
+       --without-tcl
 
 # needed for openssl detection when statically linking (as ssl needs lz)
 WVSTREAMS_CONF_ENV += LIBS=-lz
@@ -38,13 +39,6 @@ else
        WVSTREAMS_CONF_OPT += --without-dbus
 endif
 
-ifeq ($(BR2_PACKAGE_TCL),y)
-       WVSTREAMS_DEPENDENCIES += tcl
-       WVSTREAMS_CONF_OPT += --with-tcl
-else
-       WVSTREAMS_CONF_OPT += --without-tcl
-endif
-
 ifeq ($(BR2_PACKAGE_QT),y)
        WVSTREAMS_DEPENDENCIES += qt
        WVSTREAMS_CONF_OPT += --with-qt