package/bats-core: new package
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Apr 2019 13:21:42 +0000 (15:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 3 Apr 2019 20:24:46 +0000 (22:24 +0200)
A bash-based automated testing system.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/bats-core/Config.in [new file with mode: 0644]
package/bats-core/bats-core.hash [new file with mode: 0644]
package/bats-core/bats-core.mk [new file with mode: 0644]

index 4ffb473487db7135e811d6d49d834b3a41f64a3d..36e3ab20c865ebea1b7a930cb51f5d28ddee10f5 100644 (file)
@@ -1715,6 +1715,7 @@ F:        configs/orangepi_pc_defconfig
 F:     configs/pandaboard_defconfig
 F:     configs/roseapplepi_defconfig
 F:     configs/sheevaplug_defconfig
+F:     package/bats-core/
 F:     package/docker-compose/
 F:     package/dump1090/
 F:     package/flickcurl/
index 6fd047ec8c8ee2ef9a626a34f1222e01e1d21ab5..e5a93dba1f5e28b835a164dc54b80b7210a7c571 100644 (file)
@@ -138,6 +138,7 @@ menu "Debugging, profiling and benchmark"
 endmenu
 
 menu "Development tools"
+       source "package/bats-core/Config.in"
        source "package/binutils/Config.in"
        source "package/bsdiff/Config.in"
        source "package/bustle/Config.in"
diff --git a/package/bats-core/Config.in b/package/bats-core/Config.in
new file mode 100644 (file)
index 0000000..73c38e5
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_BATS_CORE
+       bool "bats"
+       depends on BR2_PACKAGE_BASH # runtime
+       help
+         Bats: Bash Automated Testing System
+
+         Bats is a TAP-compliant testing framework for Bash. It
+         provides a simple way to verify that the UNIX programs you
+         write behave as expected.
+
+         https://github.com/bats-core/bats-core
diff --git a/package/bats-core/bats-core.hash b/package/bats-core/bats-core.hash
new file mode 100644 (file)
index 0000000..04e00ab
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally calculated
+sha256 855d8b8bed466bc505e61123d12885500ef6fcdb317ace1b668087364717ea82  bats-core-v1.1.0.tar.gz
+
+# License files
+sha256 55074b2b3b87809105034e1468e59076554d76a80c67bcc592000cc3d929852d  LICENSE.md
diff --git a/package/bats-core/bats-core.mk b/package/bats-core/bats-core.mk
new file mode 100644 (file)
index 0000000..739e7fc
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# bats-core
+#
+################################################################################
+
+BATS_CORE_VERSION = v1.1.0
+BATS_CORE_SITE = $(call github,bats-core,bats-core,$(BATS_CORE_VERSION))
+BATS_CORE_LICENSE = MIT
+BATS_CORE_LICENSE_FILES = LICENSE.md
+
+define BATS_CORE_INSTALL_TARGET_CMDS
+       $(@D)/install.sh $(TARGET_DIR)/usr
+endef
+
+$(eval $(generic-package))