harfbuzz: enable optional graphite2 support
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Thu, 14 Jan 2016 16:20:52 +0000 (13:20 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 14 Jan 2016 19:48:46 +0000 (20:48 +0100)
Enable building harfbuzz with the optional graphite2 support.
Also switch --without-X configure options to the correct/documented
--with-X=no syntax.

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/harfbuzz/harfbuzz.mk

index 36b291a2ba9f44cf9e783742f12229d9597ef983..c704f3262ad714f041546b84342a9bbe2dcdefce 100644 (file)
@@ -10,16 +10,16 @@ HARFBUZZ_SOURCE = harfbuzz-$(HARFBUZZ_VERSION).tar.bz2
 HARFBUZZ_LICENSE = MIT, ISC (ucdn library)
 HARFBUZZ_LICENSE_FILES = COPYING src/hb-ucdn/COPYING
 HARFBUZZ_INSTALL_STAGING = YES
-HARFBUZZ_CONF_OPTS = --without-coretext --without-uniscribe --without-graphite2
+HARFBUZZ_CONF_OPTS = --with-coretext=no --with-uniscribe=no
 
 # freetype & glib2 support required by host-pango
 HOST_HARFBUZZ_DEPENDENCIES = \
        host-freetype \
        host-libglib2
 HOST_HARFBUZZ_CONF_OPTS = \
-       --without-corext \
-       --without-uniscribe \
-       --without-graphite2 \
+       --with-coretext=no \
+       --with-uniscribe=no \
+       --with-graphite2=no \
        --with-cairo=no \
        --with-icu=no \
        --with-freetype=yes \
@@ -44,6 +44,13 @@ else
 HARFBUZZ_CONF_OPTS += --with-freetype=no
 endif
 
+ifeq ($(BR2_PACKAGE_GRAPHITE2),y)
+HARFBUZZ_DEPENDENCIES += graphite2
+HARFBUZZ_CONF_OPTS += --with-graphite2=yes
+else
+HARFBUZZ_CONF_OPTS += --with-graphite2=no
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
 HARFBUZZ_DEPENDENCIES += libglib2
 HARFBUZZ_CONF_OPTS += --with-glib=yes