projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6d938bc
)
package/ffmpeg: add support for libressl
author
Bernd Kuhls
<bernd.kuhls@t-online.de>
Mon, 2 Apr 2018 11:58:26 +0000
(13:58 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 16:29:46 +0000
(18:29 +0200)
Ffmpeg builds fine with current libressl 2.7.2.
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ffmpeg/ffmpeg.mk
patch
|
blob
|
history
diff --git
a/package/ffmpeg/ffmpeg.mk
b/package/ffmpeg/ffmpeg.mk
index 71d642cf4c3db27a3b2c8324b99463a87c4575c0..432e4cda09cd6ccc01c135e708788d2eb3f52529 100644
(file)
--- a/
package/ffmpeg/ffmpeg.mk
+++ b/
package/ffmpeg/ffmpeg.mk
@@
-214,13
+214,13
@@
FFMPEG_CONF_OPTS += --enable-gnutls --disable-openssl
FFMPEG_DEPENDENCIES += gnutls
else
FFMPEG_CONF_OPTS += --disable-gnutls
-ifeq ($(BR2_PACKAGE_
LIB
OPENSSL),y)
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
# openssl isn't license compatible with GPL
ifeq ($(BR2_PACKAGE_FFMPEG_GPL)x$(BR2_PACKAGE_FFMPEG_NONFREE),yx)
FFMPEG_CONF_OPTS += --disable-openssl
else
FFMPEG_CONF_OPTS += --enable-openssl
-FFMPEG_DEPENDENCIES +=
lib
openssl
+FFMPEG_DEPENDENCIES += openssl
endif
else
FFMPEG_CONF_OPTS += --disable-openssl