package/leafnode2: fix news user check
authorRomain Naour <romain.naour@openwide.fr>
Fri, 26 Dec 2014 17:38:11 +0000 (18:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Dec 2014 16:11:26 +0000 (17:11 +0100)
--enable-runas-user use 'news' as default but the configure stop
if news doesn't exist on the build host.
Use 'root' while cross-compiling

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/leafnode2/leafnode2.mk

index 3bc1c684583d0a4b87eef46bb1d67156590c41ca..0fc2a8d70592f27c1fb4adb2e02f695fac392042 100644 (file)
@@ -14,9 +14,13 @@ LEAFNODE2_DEPENDENCIES = host-pcre pcre
 LEAFNODE2_CONF_ENV = \
        PCRECONFIG="$(STAGING_DIR)/usr/bin/pcre-config"
 
+# --enable-runas-user use 'news' as default but the configure stop
+# if news doesn't exist on the build host.
+# Use 'root' while cross-compiling 
 LEAFNODE2_CONF_OPTS = \
        --sysconfdir=/etc/leafnode2 \
-       --enable-spooldir=/var/spool/news
+       --enable-spooldir=/var/spool/news \
+       --enable-runas-user=root
 
 # Leafnode2 needs the host version of b_sortnl during
 # compilation. Instead of creating a seperate host package and