gst-ffmpeg: add --pkg-config to internal libav configure options
authorDanomi Manchego <danomimanchego123@gmail.com>
Sun, 19 Oct 2014 19:33:20 +0000 (15:33 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Oct 2014 15:50:00 +0000 (16:50 +0100)
The internal copy of libav in gst-ffmpeg does not understand the
PKG_CONFIG env variable, so it throws a line like this at the end
of its configuration:

WARNING: .../output/host/usr/bin/i686-pc-linux-gnu-pkg-config not found, library detection may fail.

This patch adds the --pkg-config to let libav know where it is.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Tested-by: Luca Ceresoli <luca@lucaceresoli.net>
Reviewed-by: Luca Ceresoli <luca@lucaceresoli.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk

index 44d3acec60d35a97aeca5f13111b0f6d03c418f5..984b64c0bd5cfa35cbc3018823a6df3865b32e41 100644 (file)
@@ -22,7 +22,8 @@ endif
 
 GST_FFMPEG_CONF_EXTRA_OPTS = \
                --cross-prefix=$(TARGET_CROSS) \
-               --target-os=linux
+               --target-os=linux \
+               --pkg-config='$(PKG_CONFIG_HOST_BINARY)'
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 GST_FFMPEG_CONF_EXTRA_OPTS += --enable-zlib