keyutils: uses dl*, disable for static build
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 31 May 2015 12:35:34 +0000 (14:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 31 May 2015 12:35:34 +0000 (14:35 +0200)
And drop the unused static handling from the .mk file.

Fixes:
http://autobuild.buildroot.net/results/8a2/8a2ff0af4faeda4d2d224dcaf543a574d7eba30c/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ecryptfs-utils/Config.in
package/keyutils/Config.in
package/keyutils/keyutils.mk

index d243da6fd4cc3c1fae172ec17eba03b81db143d5..cb70e000aedb6a80c4fa60b11f4acd9afc05b94a 100644 (file)
@@ -13,7 +13,7 @@ config BR2_PACKAGE_ECRYPTFS_UTILS
        depends on BR2_TOOLCHAIN_HAS_THREADS # libnss -> libnspr
        depends on BR2_PACKAGE_LIBNSPR_ARCH_SUPPORT # libnss -> libnspr
        depends on !BR2_MIPS_NABI32 # libnss
-       depends on !BR2_STATIC_LIBS # libnss
+       depends on !BR2_STATIC_LIBS # libnss, keyutils
        help
          eCryptfs is a POSIX-compliant enterprise cryptographic
          filesystem for Linux. It is stacked on top of any other
index fcb075fa911cd0fd0c7f4b36b296d96ac7eca175..6f0758f47324a25bf45a92dc845d12a632d3c2f5 100644 (file)
@@ -2,8 +2,14 @@ config BR2_PACKAGE_KEYUTILS
        bool "keyutils"
        depends on !BR2_microblaze
        depends on BR2_USE_MMU # fork()
+       depends on !BR2_STATIC_LIBS # dlopen
        help
          These tools are used to control the key management system
          built into the Linux kernel.
 
          http://people.redhat.com/~dhowells/keyutils/
+
+comment "keyutils needs a toolchain w/ dynamic library"
+       depends on !BR2_microblaze
+       depends on BR2_USE_MMU
+       depends on BR2_STATIC_LIBS
index 36588e6c377491db6feb2cb59f5a685551f7d957..3d6697eb9bf46db46d9d7419c0149d568fbc45e6 100644 (file)
@@ -19,10 +19,6 @@ KEYUTILS_MAKE_PARAMS =                    \
        CPPFLAGS="$(TARGET_CPPFLAGS) -I." \
        LNS="$(HOSTLN) -sf"
 
-ifeq ($(BR2_STATIC_LIBS),y)
-KEYUTILS_MAKE_PARAMS += NO_SOLIB=1
-endif
-
 ifeq ($(BR2_SHARED_LIBS),y)
 KEYUTILS_MAKE_PARAMS += NO_ARLIB=1
 endif