systemd: sort SYSTEMD_CONF_OPTS
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Nov 2020 21:09:38 +0000 (22:09 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 3 Nov 2020 21:17:55 +0000 (22:17 +0100)
The meson options were in some semi-sorted order with no logic in it.
Sort them alphabetically instead.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/systemd/systemd.mk

index 63885993dbf8ad5fd169dd79ba752462af243526..cb12f667d6ecff1b8c269af17b0b9cb423aa81c3 100644 (file)
@@ -23,32 +23,32 @@ SYSTEMD_SELINUX_MODULES = systemd udev
 SYSTEMD_PROVIDES = udev
 
 SYSTEMD_CONF_OPTS += \
-       -Drootlibdir='/usr/lib' \
-       -Dsysvinit-path= \
-       -Dsysvrcnd-path= \
-       -Dutmp=false \
-       -Dman=false \
+       -Ddefault-hierarchy=hybrid \
+       -Didn=true \
        -Dima=false \
+       -Dkexec-path=/usr/sbin/kexec \
+       -Dkmod-path=/usr/bin/kmod \
        -Dldconfig=false \
-       -Ddefault-hierarchy=hybrid \
-       -Dtests=false \
+       -Dloadkeys-path=/usr/bin/loadkeys \
+       -Dman=false \
+       -Dmount-path=/usr/bin/mount \
+       -Dnss-systemd=true \
+       -Dportabled=false \
+       -Dquotacheck-path=/usr/sbin/quotacheck \
+       -Dquotaon-path=/usr/sbin/quotaon \
+       -Drootlibdir='/usr/lib' \
+       -Dsetfont-path=/usr/bin/setfont \
        -Dsplit-bin=true \
        -Dsplit-usr=false \
-       -Dsystem-uid-max=999 \
+       -Dsulogin-path=/usr/sbin/sulogin \
        -Dsystem-gid-max=999 \
+       -Dsystem-uid-max=999 \
+       -Dsysvinit-path= \
+       -Dsysvrcnd-path= \
        -Dtelinit-path= \
-       -Dquotaon-path=/usr/sbin/quotaon \
-       -Dquotacheck-path=/usr/sbin/quotacheck \
-       -Dkmod-path=/usr/bin/kmod \
-       -Dkexec-path=/usr/sbin/kexec \
-       -Dsulogin-path=/usr/sbin/sulogin \
-       -Dmount-path=/usr/bin/mount \
+       -Dtests=false \
        -Dumount-path=/usr/bin/umount \
-       -Dloadkeys-path=/usr/bin/loadkeys \
-       -Dsetfont-path=/usr/bin/setfont \
-       -Didn=true \
-       -Dnss-systemd=true \
-       -Dportabled=false
+       -Dutmp=false
 
 ifeq ($(BR2_PACKAGE_ACL),y)
 SYSTEMD_DEPENDENCIES += acl