libgit2: do not use a bundled zlib
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Fri, 1 Jun 2018 15:41:58 +0000 (17:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 4 Jun 2018 20:45:35 +0000 (22:45 +0200)
libgit2 depends on zlib. If libgit2's build system does not find a
system zlib, then it compiles a bundled version of it, which is not
really great. So instead, add zlib as a mandatory dependency.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libgit2/Config.in
package/libgit2/libgit2.mk

index 24a1f3b5a9e1b04bb4c888369473ffe7c6bdb347..53ba4d42456b827f8b9f5190be5a9b4aa8f130d8 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_LIBGIT2
        bool "libgit2"
+       select BR2_PACKAGE_ZLIB
        help
          libgit2 is a portable, pure C implementation of the Git core
          methods provided as a linkable library with a solid API,
index 277a8d46ac18e5ddc18c2342fd75e15425965c49..fcace3929011b7d97ffca7311686eabc8c904e50 100644 (file)
@@ -16,6 +16,8 @@ LIBGIT2_CONF_OPTS = \
        -DUSE_ICONV=ON \
        -DTHREADSAFE=$(if $(BR2_TOOLCHAIN_HAS_THREADS),ON,OFF)
 
+LIBGIT2_DEPENDENCIES = zlib
+
 # If libiconv is available (for !locale toolchains), then we can use
 # it for iconv support. Note that USE_ICONV=ON is still correct even
 # without libiconv because (1) most toolchain have iconv support
@@ -25,11 +27,6 @@ ifeq ($(BR2_PACKAGE_LIBICONV),y)
 LIBGIT2_DEPENDENCIES += libiconv
 endif
 
-# No option to explicitly enable/disable zlib
-ifeq ($(BR2_PACKAGE_ZLIB),y)
-LIBGIT2_DEPENDENCIES += zlib
-endif
-
 ifeq ($(BR2_PACKAGE_LIBSSH2),y)
 LIBGIT2_DEPENDENCIES += libssh2
 LIBGIT2_CONF_OPTS += -DUSE_SSH=ON