release: remove manual build files from release tarballs
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Fri, 17 Jul 2015 10:20:35 +0000 (12:20 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 17 Jul 2015 17:44:53 +0000 (19:44 +0200)
The Buildroot release tarballs inadvertently contain a build/docs directory,
containing the manual sources, the generated lists, and manual.text and
manual.pdf (but excluding manual.html).

This directory is populated as $(BUILD_DIR) (==$(O)/build), while O is
set explicitly from the release target to a subdirectory
buildroot-xxxx.yy-git/ which was populated with 'git archive'.

Since the generated manuals are available in docs/manual, which is
also referred to from the README, the build directory is not needed and
should be removed from the release tarball.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 531ac5dc388985a19fe5212015815368173f16a8..168d62a3a29fd17e5788b087fa07256a1fe08cf8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -936,6 +936,7 @@ release: OUT = buildroot-$(BR2_VERSION)
 release:
        git archive --format=tar --prefix=$(OUT)/ HEAD > $(OUT).tar
        $(MAKE) O=$(OUT) manual-html manual-text manual-pdf
+       $(MAKE) O=$(OUT) manual-clean
        tar rf $(OUT).tar $(OUT)
        gzip -9 -c < $(OUT).tar > $(OUT).tar.gz
        bzip2 -9 -c < $(OUT).tar > $(OUT).tar.bz2