lttng-libust: enable Python agent when Python is available
authorPhilippe Proulx <eeppeliteloop@gmail.com>
Mon, 31 Oct 2016 07:46:17 +0000 (03:46 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Nov 2016 14:05:58 +0000 (15:05 +0100)
Add the --enable-python-agent configure option to build the LTTng-UST
Python agent when Python 2 or Python 3 is also part of the BR image. The
LTTng-UST Python agent is a Python package which adds LTTng tracing to
Python's standard logging when imported.

Disable the Python agent otherwise.

Signed-off-by: Philippe Proulx <eeppeliteloop@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lttng-libust/lttng-libust.mk

index feeeb4325d15be5a6a33f872a3f24ed2835028d5..7a83f46421d958835e08388bb9b7d81c57d4c137 100644 (file)
@@ -15,10 +15,13 @@ LTTNG_LIBUST_CONF_OPTS += --disable-man-pages
 
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 LTTNG_LIBUST_DEPENDENCIES += python
+LTTNG_LIBUST_CONF_OPTS += --enable-python-agent
 else ifeq ($(BR2_PACKAGE_PYTHON3),y)
 LTTNG_LIBUST_DEPENDENCIES += python3
+LTTNG_LIBUST_CONF_OPTS += --enable-python-agent
 else
 LTTNG_LIBUST_CONF_ENV = am_cv_pathless_PYTHON="none"
+LTTNG_LIBUST_CONF_OPTS += --disable-python-agent
 endif
 
 $(eval $(autotools-package))