package/expedite: move to package directory
authorRomain Naour <romain.naour@openwide.fr>
Sat, 12 Dec 2015 13:33:04 +0000 (14:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Dec 2015 13:37:04 +0000 (14:37 +0100)
There is no advantage for efl related packages to share the same version
number anymore (except for Efl and Elementary).

Here are the version number used for the 1.15 stable release:
EFL                     1.15.2
Elementary              1.15.2
Emotion Generic Players 1.15.0
Evas Generic Loaders    1.15.0
Python-EFL              1.15.0

Also, we usually do not have a sub-directory for a family of related
packages which don't share the same version number, so move expedite
to the package directory. Expedite now appears in the
"Graphic libraries and applications (graphic/text)" in the Kconfig menu.

In a followup patch, expedite will be downloaded directly from the 1.15
branch in the git repository since there is no new tarball release after
1.7.0.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/efl/Config.in
package/efl/expedite/Config.in [deleted file]
package/efl/expedite/expedite.mk [deleted file]
package/expedite/Config.in [new file with mode: 0644]
package/expedite/expedite.mk [new file with mode: 0644]

index 0eb6fda0109c6b2626f5093d1f5b2cc538967a1a..9610423145e2820923719fb03e353a5c0401b287 100644 (file)
@@ -220,6 +220,7 @@ endmenu
 menu "Graphic libraries and applications (graphic/text)"
 
 comment "Graphic applications"
+       source "package/expedite/Config.in"
        source "package/fswebcam/Config.in"
        source "package/glmark2/Config.in"
        source "package/gnuplot/Config.in"
index 3d31a2609f40d91f061eaab9151f053a7856a8a7..cb91660afc1d0ec90581545a796537c2ef89537e 100644 (file)
@@ -10,7 +10,6 @@ menuconfig BR2_PACKAGE_EFL
 
 if BR2_PACKAGE_EFL
 
-source "package/efl/expedite/Config.in"
 source "package/efl/libeina/Config.in"
 source "package/efl/libecore/Config.in"
 source "package/efl/libeet/Config.in"
diff --git a/package/efl/expedite/Config.in b/package/efl/expedite/Config.in
deleted file mode 100644 (file)
index 1e12108..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-config BR2_PACKAGE_EXPEDITE
-       bool "expedite"
-       select BR2_PACKAGE_LIBEINA
-       select BR2_PACKAGE_LIBEVAS
-       select BR2_PACKAGE_LIBEET
-       depends on BR2_INSTALL_LIBSTDCPP
-       depends on BR2_TOOLCHAIN_HAS_THREADS # libevas
-       help
-         Expedite is the official Evas benchmark tool. It can test different
-         engines, such as X11, XRender, OpenGL (also ES variant), SDL,
-         DirectFB and so on. Its tests are quite extensive, trying to
-         reproduce real world usage cases.
-
-comment "expedite needs a toolchain w/ C++, threads"
-       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/efl/expedite/expedite.mk b/package/efl/expedite/expedite.mk
deleted file mode 100644 (file)
index 9b232f8..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-################################################################################
-#
-# expedite
-#
-################################################################################
-
-EXPEDITE_VERSION = 1.7.10
-EXPEDITE_SITE = http://download.enlightenment.org/releases
-EXPEDITE_LICENSE = BSD-2c
-EXPEDITE_LICENSE_FILES = COPYING
-
-EXPEDITE_DEPENDENCIES = libevas libeina libeet
-
-ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
-EXPEDITE_CONF_OPTS += --with-x=$(STAGING_DIR) \
-       --x-includes=$(STAGING_DIR)/usr/include \
-       --x-libraries=$(STAGING_DIR)/usr/lib
-endif
-
-$(eval $(autotools-package))
diff --git a/package/expedite/Config.in b/package/expedite/Config.in
new file mode 100644 (file)
index 0000000..de6a056
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_EXPEDITE
+       bool "expedite"
+       select BR2_PACKAGE_LIBEINA
+       select BR2_PACKAGE_LIBEVAS
+       select BR2_PACKAGE_LIBEET
+       depends on BR2_PACKAGE_EFL
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libevas
+       help
+         Expedite is the official Evas benchmark tool. It can test different
+         engines, such as X11, XRender, OpenGL (also ES variant), SDL,
+         DirectFB and so on. Its tests are quite extensive, trying to
+         reproduce real world usage cases.
+
+comment "expedite needs a toolchain w/ C++, threads"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/expedite/expedite.mk b/package/expedite/expedite.mk
new file mode 100644 (file)
index 0000000..9b232f8
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# expedite
+#
+################################################################################
+
+EXPEDITE_VERSION = 1.7.10
+EXPEDITE_SITE = http://download.enlightenment.org/releases
+EXPEDITE_LICENSE = BSD-2c
+EXPEDITE_LICENSE_FILES = COPYING
+
+EXPEDITE_DEPENDENCIES = libevas libeina libeet
+
+ifeq ($(BR2_PACKAGE_LIBEVAS_X11),y)
+EXPEDITE_CONF_OPTS += --with-x=$(STAGING_DIR) \
+       --x-includes=$(STAGING_DIR)/usr/include \
+       --x-libraries=$(STAGING_DIR)/usr/lib
+endif
+
+$(eval $(autotools-package))