package/perl-net-http: New package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 19 Apr 2015 10:17:11 +0000 (12:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 11:43:45 +0000 (13:43 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-net-http/Config.in [new file with mode: 0644]
package/perl-net-http/perl-net-http.hash [new file with mode: 0644]
package/perl-net-http/perl-net-http.mk [new file with mode: 0644]

index 0066da9f1e91a388e86b3ef12099694bbe1d479c..b3c87d6b7276f9aa76b1bf69320fe3a2bfe4b865 100644 (file)
@@ -523,6 +523,7 @@ menu "Perl libraries/modules"
        source "package/perl-lwp-mediatypes/Config.in"
        source "package/perl-mojolicious/Config.in"
        source "package/perl-net-dns/Config.in"
+       source "package/perl-net-http/Config.in"
        source "package/perl-net-ssleay/Config.in"
        source "package/perl-netaddr-ip/Config.in"
        source "package/perl-path-tiny/Config.in"
diff --git a/package/perl-net-http/Config.in b/package/perl-net-http/Config.in
new file mode 100644 (file)
index 0000000..6f18dd5
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PERL_NET_HTTP
+       bool "perl-net-http"
+       select BR2_PACKAGE_PERL_URI
+       help
+         The `Net::HTTP' class is a low-level HTTP client.
+
+         http://github.com/libwww-perl/net-http
diff --git a/package/perl-net-http/perl-net-http.hash b/package/perl-net-http/perl-net-http.hash
new file mode 100644 (file)
index 0000000..9f5f11b
--- /dev/null
@@ -0,0 +1,3 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    b6da691523456089d7a812ac398bc77e Net-HTTP-6.07.tar.gz
+sha256 9f31e0325a5a0930ad309fa019da9d208e57e236fb0598675ed883c820240364 Net-HTTP-6.07.tar.gz
diff --git a/package/perl-net-http/perl-net-http.mk b/package/perl-net-http/perl-net-http.mk
new file mode 100644 (file)
index 0000000..a73dfec
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-net-http
+#
+################################################################################
+
+PERL_NET_HTTP_VERSION = 6.07
+PERL_NET_HTTP_SOURCE = Net-HTTP-$(PERL_NET_HTTP_VERSION).tar.gz
+PERL_NET_HTTP_SITE = $(BR2_CPAN_MIRROR)/authors/id/M/MS/MSCHILLI
+PERL_NET_HTTP_DEPENDENCIES = perl-uri
+PERL_NET_HTTP_LICENSE = Artistic or GPLv1+
+PERL_NET_HTTP_LICENSE_FILES = README
+
+$(eval $(perl-package))