package/pkg-generic.mk: in image install, print message before pre-hooks
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 28 Feb 2020 15:04:20 +0000 (16:04 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 29 Feb 2020 16:47:47 +0000 (17:47 +0100)
In all steps, we print the message indicating the start of the step
using the MESSAGE macro before running pre-hooks. Except in the image
installation step, where the message is printed after the pre-hooks.

Let's fix this inconsistency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-generic.mk

index 7b240ca01237f5c3d372fcaf94676e101d0b6afd..c1b9fe2e59743c9ca1ae3bc915281156a16b809b 100644 (file)
@@ -347,8 +347,8 @@ $(BUILD_DIR)/%/.stamp_staging_installed:
 $(BUILD_DIR)/%/.stamp_images_installed:
        @$(call step_start,install-image)
        @mkdir -p $(BINARIES_DIR)
-       $(foreach hook,$($(PKG)_PRE_INSTALL_IMAGES_HOOKS),$(call $(hook))$(sep))
        @$(call MESSAGE,"Installing to images directory")
+       $(foreach hook,$($(PKG)_PRE_INSTALL_IMAGES_HOOKS),$(call $(hook))$(sep))
        +$($(PKG)_INSTALL_IMAGES_CMDS)
        $(foreach hook,$($(PKG)_POST_INSTALL_IMAGES_HOOKS),$(call $(hook))$(sep))
        @$(call step_end,install-image)