gpm: run autogen.sh as PRE_CONFIGURE step
authorRyan Barnett <ryanbarnett3@gmail.com>
Tue, 4 Feb 2014 09:38:57 +0000 (10:38 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 4 Feb 2014 09:49:42 +0000 (10:49 +0100)
Move the GPM_RUN_AUTOGEN to be a PRE_CONFIGURE step because this step
depends on the dependancies being built. If it is a POST_PATCH step
the dependencies won't be built and the GPM_RUN_AUTOGEN step will fail
(if the host doesn't have autotools).

Signed-off-by: Ryan Barnett <rjbarnet@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gpm/gpm.mk

index 296966addc8561e2376b430341bfbdd354ade6be..58fab0047f74333d817a50c7abaa20e695637e43 100644 (file)
@@ -28,7 +28,7 @@ GPM_CONF_OPT = --without-curses
 define GPM_RUN_AUTOGEN
        cd $(@D) && PATH=$(HOST_PATH) ./autogen.sh
 endef
-GPM_POST_PATCH_HOOKS += GPM_RUN_AUTOGEN
+GPM_PRE_CONFIGURE_HOOKS += GPM_RUN_AUTOGEN
 
 GPM_DEPENDENCIES += host-automake host-autoconf host-libtool