libnice: bump to version 0.1.14
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 4 May 2018 21:18:12 +0000 (23:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 6 May 2018 07:06:09 +0000 (09:06 +0200)
- Remove patch (already in version)
- Add gnutls mandatory dependency
- Add hash for license files

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libnice/0001-configure-Fix-configure-failure-when-building-without-.patch [deleted file]
package/libnice/Config.in
package/libnice/libnice.hash
package/libnice/libnice.mk

diff --git a/package/libnice/0001-configure-Fix-configure-failure-when-building-without-.patch b/package/libnice/0001-configure-Fix-configure-failure-when-building-without-.patch
deleted file mode 100644 (file)
index f6b2eb4..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-From 81a929ac141aae66b6450e8ce93cb357ed404cda Mon Sep 17 00:00:00 2001
-From: Timo Gurr <timo.gurr@gmail.com>
-Date: Mon, 1 Jun 2015 16:10:16 +0200
-Subject: [PATCH] configure: Fix configure failure when building without
- gstreamer support
-
-Error introduced in 20ea22e0a11a9bdfe4d8125b68083249b694338a, resulting in a
-configure/build error when building without gstreamer:
-
-configure: error: conditional "HAVE_GST_CHECK" was never defined.
-Usually this means the macro was only invoked conditionally.
-
-https://bugs.freedesktop.org/show_bug.cgi?id=90801
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
----
-Patch status: upstream
-
- configure.ac | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 6031cec..64a571f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -231,9 +231,6 @@ AS_IF([test "$with_gstreamer" != no], [
-               [
-               have_gst_check=no
-               ])
--
--      AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
--
- ])
- AS_IF([test "$with_gstreamer010" != no], [
-@@ -260,6 +257,7 @@ AC_SUBST(gstplugindir)
- AC_SUBST(gstplugin010dir)
- AM_CONDITIONAL(WITH_GSTREAMER, test "$with_gstreamer" = yes)
-+AM_CONDITIONAL(HAVE_GST_CHECK, test "$have_gst_check" = yes)
- AM_CONDITIONAL(WITH_GSTREAMER010, test "$with_gstreamer010" = yes)
- GUPNP_IGD_REQUIRED=0.2.4
--- 
-2.10.2
-
index c803a3172090ae682c1e6419788ba76def1fc348..af8e8146186fdf82c9bcf7dc2a833962773f382f 100644 (file)
@@ -1,8 +1,10 @@
 config BR2_PACKAGE_LIBNICE
        bool "libnice"
+       depends on !BR2_STATIC_LIBS # gnutls
        depends on BR2_USE_WCHAR # libglib2
        depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
        depends on BR2_USE_MMU # fork()
+       select BR2_PACKAGE_GNUTLS
        select BR2_PACKAGE_LIBGLIB2
        help
          Libnice is an implementation of the IETF's Interactive
@@ -15,6 +17,7 @@ config BR2_PACKAGE_LIBNICE
 
          http://nice.freedesktop.org/wiki/
 
-comment "libnice needs a toolchain w/ wchar, threads"
+comment "libnice needs a toolchain w/ wchar, threads, dynamic library"
        depends on BR2_USE_MMU
-       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS || \
+               BR2_STATIC_LIBS
index d08c2d783973708778ead979798896ae5ea04d73..3c1f0d845ac763209e9c12c2584906b8622dc29d 100644 (file)
@@ -1,2 +1,7 @@
 # Locally computed after checking pgp signature
-sha256 61112d9f3be933a827c8365f20551563953af6718057928f51f487bfe88419e1 libnice-0.1.13.tar.gz
+sha256 be120ba95d4490436f0da077ffa8f767bf727b82decf2bf499e39becc027809c libnice-0.1.14.tar.gz
+
+# Hash for license files:
+sha256 9246b2ee8b1db30cf03d5d9719ad8bb5edce1cadc85f8cfef319c23d24d950b5 COPYING
+sha256 3b3c75ae6c663c4f93987647eb5463d33dc1602a1aded3ac479773f2c3928e3a COPYING.MPL
+sha256 a9bdde5616ecdd1e980b44f360600ee8783b1f99b8cc83a2beb163a0a390e861 COPYING.LGPL
index 6afcb7635a80096dc56e8b3625f30f0863571654..e023728f44836cf43c9066937512df086119c169 100644 (file)
@@ -4,14 +4,12 @@
 #
 ################################################################################
 
-LIBNICE_VERSION = 0.1.13
+LIBNICE_VERSION = 0.1.14
 LIBNICE_SITE = http://nice.freedesktop.org/releases
 LIBNICE_LICENSE = MPL-1.1 or LGPL-2.1
 LIBNICE_LICENSE_FILES = COPYING COPYING.MPL COPYING.LGPL
-LIBNICE_DEPENDENCIES = libglib2 host-pkgconf
+LIBNICE_DEPENDENCIES = gnutls libglib2 host-pkgconf
 LIBNICE_INSTALL_STAGING = YES
-# For 0001-configure-Fix-configure-failure-when-building-without-.patch
-LIBNICE_AUTORECONF = YES
 LIBNICE_CONF_OPTS = \
        --without-gstreamer \
        --without-gstreamer-0.10