cairo: add freetype and gobject support
authorHadrien Boutteville <hadrien.boutteville@gmail.com>
Tue, 8 Jul 2014 13:57:06 +0000 (15:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Jul 2014 21:19:42 +0000 (23:19 +0200)
Signed-off-by: Hadrien Boutteville <hadrien.boutteville@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cairo/cairo.mk

index 789dfa7ba299acf3562525fcaf137033dda5a14f..a4c71b6816e06244844869a8684127eb93c2bd7f 100644 (file)
@@ -55,6 +55,20 @@ else
        CAIRO_CONF_OPT += --disable-directfb
 endif
 
+ifeq ($(BR2_PACKAGE_FREETYPE),y)
+       CAIRO_CONF_OPT += --enable-ft
+       CAIRO_DEPENDENCIES += freetype
+else
+       CAIRO_CONF_OPT += --disable-ft
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+       CAIRO_CONF_OPT += --enable-gobject
+       CAIRO_DEPENDENCIES += libglib2
+else
+       CAIRO_CONF_OPT += --disable-gobject
+endif
+
 ifeq ($(BR2_PACKAGE_HAS_LIBGLES),y)
        CAIRO_CONF_OPT += --enable-glesv2
        CAIRO_DEPENDENCIES += libgles