openvpn: adjust iproute2 path logic
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 4 Apr 2013 11:32:53 +0000 (11:32 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 7 Apr 2013 07:43:32 +0000 (09:43 +0200)
As reported in bug #6164 when using busybox iproute2 openvpn can fail to
locate the 'ip' utility.
This was correct until busybox 1.21.0 was released since it changed the
location of /bin/ip to /sbin/ip (what iproute2 proper does).
So adjust the ip path accordingly.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/openvpn/openvpn.mk

index c911465259b6ed0cdca797a8c70a5846e75bc378..7a4385b63dd3e891e28fdad1a0333a27f077b6ef 100644 (file)
@@ -17,10 +17,14 @@ OPENVPN_CONF_OPT += --enable-small --disable-plugins \
        --disable-debug --disable-eurephia
 endif
 
+# Busybox 1.21+ places the ip applet in the "correct" place
+# but previous versions didn't.
 ifeq ($(BR2_PACKAGE_IPROUTE2),y)
 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
-else
+else ifeq ($(BR2_BUSYBOX_VERSION_1_19_X)$(BR2_BUSYBOX_VERSION_1_20_X),y)
 OPENVPN_CONF_ENV += IPROUTE=/bin/ip
+else
+OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
 endif
 
 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)