mjpg-streamer: Fix build with ccache enabled.
authorNicolas Cavallari <nicolas.cavallari@green-communications.fr>
Fri, 27 Mar 2015 16:50:36 +0000 (17:50 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 Mar 2015 17:09:36 +0000 (18:09 +0100)
Quote the TARGET_CC variable, otherwise, if ccache is enabled:

[...] make CC=$TARGET_CC [...]
is expanded to e.g.
[...] make CC=ccache gcc [...]

The build succeeds with "make[2]: Nothing to be done for '[...]gcc'".
and the program is compiled at "make install" time, with the default
host compiler, resulting in a binary that does not run on the target.

Signed-off-by: Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mjpg-streamer/mjpg-streamer.mk

index 23854292607947004ea32e07e6e7822e63b59b1d..e10e9a8b4ac981bb243644dda9979820423da635 100644 (file)
@@ -15,7 +15,7 @@ MJPG_STREAMER_LICENSE_FILES = LICENSE
 MJPG_STREAMER_DEPENDENCIES = jpeg
 
 define MJPG_STREAMER_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) CC=$(TARGET_CC) -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" -C $(@D)
 endef
 
 define MJPG_STREAMER_INSTALL_TARGET_CMDS