wine: Add gettext dependency for host-wine
authorAndré Hentschel <nerv@dawncrow.de>
Sun, 15 Mar 2015 11:35:34 +0000 (12:35 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 16 Mar 2015 21:07:30 +0000 (22:07 +0100)
Mostly based on a comment by Yann E. MORIN

Signed-off-by: André Hentschel <nerv@dawncrow.de>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wine/wine.mk

index aa474f96b6a8601cc41acba115aa4fb732761ec3..a699fff9539d188bf31c370e5156dc1b989aa241 100644 (file)
@@ -243,6 +243,10 @@ else
 WINE_CONF_OPTS += --without-zlib
 endif
 
+# host-gettext is essential for .po file support in host-wine wrc
+HOST_WINE_DEPENDENCIES += host-gettext
+HOST_WINE_CONF_OPTS += --with-gettext --with-gettextpo
+
 # Wine needs to enable 64-bit build tools on 64-bit host
 ifeq ($(HOSTARCH),x86_64)
 HOST_WINE_CONF_OPTS += --enable-win64
@@ -280,8 +284,6 @@ HOST_WINE_CONF_OPTS += \
        --without-curses \
        --without-dbus \
        --without-fontconfig \
-       --without-gettext \
-       --without-gettextpo \
        --without-gphoto \
        --without-glu \
        --without-gnutls \