toolchain-external: bump to Linaro AArch64 2013.06
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 23 Jun 2013 14:20:03 +0000 (16:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 23 Jun 2013 19:55:55 +0000 (21:55 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index ebe9fcd3080c0b069b1cd90ea1f88a55a03b1f40..2c1c99b789bb83780e964c2bcf8c417efa680d8a 100644 (file)
@@ -692,8 +692,8 @@ config BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
          Toolchain for the Microblaze architecture, from
          http://wiki.xilinx.com/mb-gnu-tools
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_05
-       bool "Linaro AArch64 13.05"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_06
+       bool "Linaro AArch64 13.06"
        depends on BR2_aarch64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
@@ -704,8 +704,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_05
          Toolchain for the AArch64 architecture, from
          http://www.linaro.org/engineering/armv8/
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_04
-       bool "Linaro AArch64 13.04"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_05
+       bool "Linaro AArch64 13.05"
        depends on BR2_aarch64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
@@ -716,13 +716,14 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_04
          Toolchain for the AArch64 architecture, from
          http://www.linaro.org/engineering/armv8/
 
-config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_03
-       bool "Linaro AArch64 13.03"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_04
+       bool "Linaro AArch64 13.04"
        depends on BR2_aarch64
        depends on BR2_HOSTARCH = "x86_64" || BR2_HOSTARCH = "x86"
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
        select BR2_INSTALL_LIBSTDCPP
        select BR2_HOSTARCH_NEEDS_IA32_LIBS
+       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
        help
          Toolchain for the AArch64 architecture, from
          http://www.linaro.org/engineering/armv8/
@@ -785,9 +786,9 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201305
        default "arm-arago-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV7A_201109
        default "arm-arago-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_ARAGO_ARMV5TE_201109
+       default "aarch64-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_06
        default "aarch64-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_05
        default "aarch64-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_04
-       default "aarch64-linux-gnu"      if BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_03
        default "microblazeel-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_14_3
        default "microblazeel-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2
        default "microblaze-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_14_3
index 2b0b23ec84dea4ebc2d9e3360e9f040bda1ab5f9..1d76a66b4b57bad62e1928fc085429f4a708023e 100644 (file)
@@ -290,15 +290,15 @@ TOOLCHAIN_EXTERNAL_SOURCE=lin32-microblaze-unknown-linux-gnu_14.3_early.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sources.buildroot.net/
 TOOLCHAIN_EXTERNAL_SOURCE=microblaze-unknown-linux-gnu.tgz
-else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_03),y)
-TOOLCHAIN_EXTERNAL_SITE=http://releases.linaro.org/13.03/components/toolchain/binaries/
-TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-aarch64-linux-gnu-4.7-2013.03-20130313_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_04),y)
 TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.04/components/toolchain/binaries/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-aarch64-linux-gnu-4.7-2013.04-20130415_linux.tar.xz
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_05),y)
 TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.05/components/toolchain/binaries/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-aarch64-linux-gnu-4.8-2013.05_linux.tar.xz
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_AARCH64_13_06),y)
+TOOLCHAIN_EXTERNAL_SITE=https://releases.linaro.org/13.06/components/toolchain/binaries/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-aarch64-linux-gnu-4.8-2013.06_linux.tar.xz
 else
 # Custom toolchain
 TOOLCHAIN_EXTERNAL_SITE=$(dir $(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_URL)))