sdl: fix directfb configure check
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Apr 2013 20:32:39 +0000 (22:32 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 28 Apr 2013 20:32:39 +0000 (22:32 +0200)
The configure script nicely supports a preconfigured directfb-config
(using ac_cv_path_DIRECTFBCONFIG), except for when it checks the directfb
version where it simply uses whatever directfb-config is in the path,
breaking the build when this isn't available / recent enough.

Fix is to use the correct one instead. As SDL doesn't autoreconf cleanly,
also patch the generated configure script.

Finally move the ac_cv_path_DIRECTFBCONFIG setting under the directfb
conditional as it is only needed there.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/sdl/sdl-use-correct-directfb-config.patch [new file with mode: 0644]
package/sdl/sdl.mk

diff --git a/package/sdl/sdl-use-correct-directfb-config.patch b/package/sdl/sdl-use-correct-directfb-config.patch
new file mode 100644 (file)
index 0000000..2250790
--- /dev/null
@@ -0,0 +1,40 @@
+[PATCH] configure.in: use correct directfb-config in version check
+
+The configure script has just checked for the correct directfb-config
+script, so also use it for the version check instead of whatever
+might be in the path.
+
+Also patch the generated configure, as it doesn't cleanly autoreconf.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ configure    |    2 +-
+ configure.in |    2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: SDL-1.2.15/configure.in
+===================================================================
+--- SDL-1.2.15.orig/configure.in
++++ SDL-1.2.15/configure.in
+@@ -1276,7 +1276,7 @@
+         else
+             set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
+             NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+-            set -- `directfb-config --version | sed 's/\./ /g'`
++            set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
+             HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+             if test $HAVE_VERSION -ge $NEED_VERSION; then
+                 DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
+Index: SDL-1.2.15/configure
+===================================================================
+--- SDL-1.2.15.orig/configure
++++ SDL-1.2.15/configure
+@@ -24958,7 +24958,7 @@
+         else
+             set -- `echo $DIRECTFB_REQUIRED_VERSION | sed 's/\./ /g'`
+             NEED_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+-            set -- `directfb-config --version | sed 's/\./ /g'`
++            set -- `$DIRECTFBCONFIG --version | sed 's/\./ /g'`
+             HAVE_VERSION=`expr $1 \* 10000 + $2 \* 100 + $3`
+             if test $HAVE_VERSION -ge $NEED_VERSION; then
+                 DIRECTFB_CFLAGS=`$DIRECTFBCONFIG --cflags`
index fb47c4d19edb6c45f9613af5d6d2a686c208949a..59576fbc4284cbaa5e982bc9b5a8746e0e040f5b 100644 (file)
@@ -8,7 +8,6 @@ SDL_VERSION = 1.2.15
 SDL_SOURCE = SDL-$(SDL_VERSION).tar.gz
 SDL_SITE = http://www.libsdl.org/release
 SDL_INSTALL_STAGING = YES
-SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
 
 ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
 SDL_CONF_OPT+=--enable-video-fbcon=yes
@@ -19,6 +18,7 @@ endif
 ifeq ($(BR2_PACKAGE_SDL_DIRECTFB),y)
 SDL_DEPENDENCIES += directfb
 SDL_CONF_OPT+=--enable-video-directfb=yes
+SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
 else
 SDL_CONF_OPT=--enable-video-directfb=no
 endif