- remove stray ';'
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 30 Jul 2007 14:22:25 +0000 (14:22 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 30 Jul 2007 14:22:25 +0000 (14:22 -0000)
target/ext2/ext2root.mk

index 4ebb9814291ab28fe2814e36f55d0d5563906176..dda8013e602518aab1353ce2aa7358a6485ba4e5 100644 (file)
@@ -87,12 +87,13 @@ EXT2_TARGET := $(EXT2_BASE)
 endif
 
 $(EXT2_BASE): host-fakeroot makedevs genext2fs
-       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
+       -@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/share/man
        @rm -rf $(TARGET_DIR)/usr/info
        @test -d $(TARGET_DIR)/usr/share && \
-               rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
+               rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share || \
+               true
        -/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))