package/mpython-m2crypto: bump version
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 6 Dec 2015 16:35:29 +0000 (17:35 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 7 Dec 2015 07:34:33 +0000 (08:34 +0100)
Fixes:

http://autobuild.buildroot.org/results/ee1/ee1bb80214a51c212712de8193b89a32e9901408/
http://autobuild.buildroot.org/results/ce8/ce8d5d68eef312ca168f351b845920eb62ca4eb1/
http://autobuild.buildroot.org/results/500/5004a2a9cabe75669bbe90f3ee35ab3869617fc9/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python-m2crypto/python-m2crypto.hash
package/python-m2crypto/python-m2crypto.mk

index a5231eca818cc1190f67177dd13b80697f5eaca7..a2603b987a75281a591ef4b5aa8ba6c773e347bc 100644 (file)
@@ -1,2 +1,2 @@
-# From https://pypi.python.org/pypi/M2Crypto/0.21.1
-md5 f93d8462ff7646397a9f77a2fe602d17 M2Crypto-0.21.1.tar.gz
+# From https://pypi.python.org/pypi/M2Crypto/0.22.5
+md5 f84eb07aa1687f39bc26ee7b1ba5a105 M2Crypto-0.22.5.tar.gz
index 7e46f1d3b4de4377009032ee034e9935e5d73f32..1f038e39cdeadfaa150204c5ce74038bfb5e51ed 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-PYTHON_M2CRYPTO_VERSION = 0.21.1
+PYTHON_M2CRYPTO_VERSION = 0.22.5
 PYTHON_M2CRYPTO_SITE = http://pypi.python.org/packages/source/M/M2Crypto
 PYTHON_M2CRYPTO_SOURCE = M2Crypto-$(PYTHON_M2CRYPTO_VERSION).tar.gz
 PYTHON_M2CRYPTO_SETUP_TYPE = setuptools
@@ -13,10 +13,16 @@ HOST_PYTHON_M2CRYPTO_DEPENDENCIES = host-openssl host-swig
 # We need to use python2 because m2crypto is not python3 compliant.
 HOST_PYTHON_M2CRYPTO_NEEDS_HOST_PYTHON = python2
 
+HOST_PYTHON_M2CRYPTO_BUILD_DIR = $(@D)/build/lib.linux-$(HOSTARCH)-$(PYTHON_VERSION_MAJOR)
+
 # * We need to override the build commands to be able to use build_ext,
 #   which accepts the --openssl option.
 # * Use python2 interpreter to avoid trying building some python3 objects.
+# * because build_ext is flawed, is forgets to copy the files prior to
+#   the build, so we do it manually.
 define HOST_PYTHON_M2CRYPTO_BUILD_CMDS
+       mkdir -p $(HOST_PYTHON_M2CRYPTO_BUILD_DIR)
+       cp -av $(@D)/M2Crypto $(HOST_PYTHON_M2CRYPTO_BUILD_DIR)/M2Crypto
        (cd $(@D); \
                $(HOST_PKG_PYTHON_SETUPTOOLS_ENV) \
                $(HOST_DIR)/usr/bin/python2 setup.py build_ext \