package/ola: fix missing numpy
authorJörg Krause <joerg.krause@embedded.rocks>
Thu, 24 Nov 2016 21:18:18 +0000 (22:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 25 Nov 2016 16:49:01 +0000 (17:49 +0100)
OLAs RDM test option needs NumPy.

Note that we need to pass `ac_cv_have_pymod_numpy=yes` as NumPy builds some
shared libraries and ola checks for NumPy using a host Python test program
which fails with 'wrong ELF class'.

Fixes:
http://autobuild.buildroot.net/results/750/750c9bcc753e2c1b7b05d6c43fabf4c405e15f04/
http://autobuild.buildroot.net/results/24a/24ada1e0ec695cb12028048728a9d1e2bcf75a03/
http://autobuild.buildroot.net/results/111/111c5f3eed6a5931de27a1b0b02be6e2114198e6/
.. and more.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ola/Config.in
package/ola/ola.mk

index 7b56f5ca9d8a246339721a3af38130d1c9c18f1f..2f1d33ef2887824be6c2e8ebac4a7fb5bc98d566 100644 (file)
@@ -54,6 +54,8 @@ config BR2_PACKAGE_OLA_EXAMPLES
 config BR2_PACKAGE_OLA_RDM_TESTS
        bool "rdm tests"
        depends on BR2_PACKAGE_OLA_PYTHON_BINDINGS
+       depends on BR2_PACKAGE_PYTHON_NUMPY_ARCH_SUPPORTS
+       select BR2_PACKAGE_PYTHON_NUMPY
        help
          Build OLA RDM tests.
 
index 75ab25e164c29c2d57f50c92eda66d7fa6ad251f..93e84a6838af6ca5fcdf683cf75578a3010a2bf6 100644 (file)
@@ -87,6 +87,11 @@ endif
 
 ifeq ($(BR2_PACKAGE_OLA_RDM_TESTS),y)
 OLA_CONF_OPTS += --enable-rdm-tests
+OLA_DEPENDENCIES += python-numpy
+# needed as numpy builds some shared libraries and ola checks for
+# numpy using a host python test program which fails with 'wrong ELF
+# class'.
+OLA_CONF_ENV = ac_cv_have_pymod_numpy=yes
 else
 OLA_CONF_OPTS += --disable-rdm-tests
 endif