libidn: fix build with config.cache, autoconf and emacs
authorPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jun 2010 06:10:13 +0000 (08:10 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 5 Jun 2010 06:10:13 +0000 (08:10 +0200)
libidn contains a few elisp files, and it's configure script checks for
emacs to know if it should install them. This is not important for BR as
we don't have emacs, but configure fails if it's available on the host,
config.cache is used and autoconf has already been used as that loads
EMACS="no" into the cache.

Fix it by also setting EMACS="no" here.

At the same time, fix up trailing spaces in Config.in.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/libidn/Config.in
package/libidn/libidn.mk

diff --git a/CHANGES b/CHANGES
index dffc84898da12117f235624b7763c71db4f2b23f..1f19a244ffcee066f6f93f0f079e3b2cee3a7fd5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -2,7 +2,7 @@
 
        Fixes all over the tree.
 
-       Updated/fixed packages: netperf
+       Updated/fixed packages: libidn, netperf
 
        Issues resolved (http://bugs.uclibc.org):
 
index 04f89007285d6a349b35e992743db09de33fc9cb..dcf972494c0241c6c5516db583c250bb48b78b28 100644 (file)
@@ -2,8 +2,8 @@ config BR2_PACKAGE_LIBIDN
        bool "libidn"
        select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
-         Libidn's purpose is to encode and decode internationalized 
-         domain names. 
+         Libidn's purpose is to encode and decode internationalized
+         domain names.
 
          http://www.gnu.org/software/libidn/
 
index 4b3bea3a56a4253dfb67cfdf26d1193fbcace2b8..79e03211db5a08ae748df1cd51c807f0695185bc 100644 (file)
@@ -8,6 +8,7 @@ LIBIDN_VERSION = 1.15
 LIBIDN_SITE = http://ftp.gnu.org/gnu/libidn/
 LIBIDN_INSTALL_STAGING = YES
 LIBIDN_INSTALL_TARGET = YES
+LIBIDN_CONF_ENV = EMACS="no"
 LIBIDN_CONF_OPT = --enable-shared --disable-java --enable-csharp=no
 LIBIDN_LIBTOOL_PATCH = NO
 LIBIDN_DEPENDENCIES = host-pkg-config $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) $(if $(BR2_PACKAGE_LIBICONV),libiconv)