package/argparse: new package
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Thu, 2 Jun 2016 15:05:53 +0000 (17:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Jun 2016 14:46:38 +0000 (16:46 +0200)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
[Thomas: remove unnecessary BR2_PACKAGE_HAS_LUAINTERPRETER dependency.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/argparse/Config.in [new file with mode: 0644]
package/argparse/argparse.hash [new file with mode: 0644]
package/argparse/argparse.mk [new file with mode: 0644]

index f1bc86db1d5a20cc432955d47e5d04dbf5672c56..3d99d72fc743a786233828619745e8da0068c4a2 100644 (file)
@@ -508,6 +508,7 @@ endif
 if BR2_PACKAGE_HAS_LUAINTERPRETER && !BR2_STATIC_LIBS
 # lua modules are dynamically loaded, so not available on static builds
 menu "Lua libraries/modules"
+       source "package/argparse/Config.in"
        source "package/cgilua/Config.in"
        source "package/copas/Config.in"
        source "package/cosmo/Config.in"
diff --git a/package/argparse/Config.in b/package/argparse/Config.in
new file mode 100644 (file)
index 0000000..d207b04
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_ARGPARSE
+       bool "argparse"
+       help
+         Argparse is a feature-rich command line parser for Lua
+         inspired by argparse for Python. Argparse supports
+         positional arguments, options, flags, optional arguments,
+         subcommands and more. Argparse automatically generates
+         usage, help and error messages.
+
+         https://github.com/mpeterv/argparse
diff --git a/package/argparse/argparse.hash b/package/argparse/argparse.hash
new file mode 100644 (file)
index 0000000..a4746bc
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 e00e5637c937d7bfca96025f2c598ba4fffe9eb818d69952e77b4c08167a6be3  argparse-0.5.0-1.src.rock
diff --git a/package/argparse/argparse.mk b/package/argparse/argparse.mk
new file mode 100644 (file)
index 0000000..095f0a3
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# argparse
+#
+################################################################################
+
+ARGPARSE_VERSION_UPSTREAM = 0.5.0
+ARGPARSE_VERSION = $(ARGPARSE_VERSION_UPSTREAM)-1
+ARGPARSE_SUBDIR = argparse
+ARGPARSE_LICENSE = MIT
+ARGPARSE_LICENSE_FILES = $(ARGPARSE_SUBDIR)/LICENSE
+
+$(eval $(luarocks-package))