target/jffs2: cleanup
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 Mar 2010 21:43:01 +0000 (22:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:04:32 +0000 (11:04 +0200)
Remove the code to build host MTD utils, since they can now be built
using package/mtd.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/jffs2/Config.in
target/jffs2/jffs2root.mk

index bcb4d5120ea5c725ac43e0799d7f44ad096185b7..bf4ac607985d9869d16806477b925fa34df5f752 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_TARGET_ROOTFS_JFFS2
        bool "jffs2 root filesystem"
-       select BR2_HOST_FAKEROOT
        help
          Build a jffs2 root filesystem
 
index 7d31417ee6a3ec51c54c22d92bce2f35fba1ac6e..30ac86ddfe7efe97dffdd595e28f6909ce0fa8cd 100644 (file)
@@ -44,7 +44,7 @@ endif
 # value of MKFS_JFFS2 to either the previously installed copy or the one
 # just built.
 #
-$(JFFS2_TARGET): host-fakeroot makedevs mtd-host
+$(JFFS2_TARGET): host-fakeroot host-mtd makedevs
        # Use fakeroot to pretend all target binaries are owned by root
        rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(JFFS2_TARGET))
        touch $(BUILD_DIR)/.fakeroot.00000
@@ -81,14 +81,6 @@ ifneq ($(JFFS2_COPYTO),)
        @cp -f $(JFFS2_TARGET) $(JFFS2_COPYTO)
 endif
 
-jffs2root-source: mtd-host-source
-
-jffs2root-clean: mtd-host-clean
-       -rm -f $(JFFS2_TARGET)
-
-jffs2root-dirclean: mtd-host-dirclean
-       -rm -f $(JFFS2_TARGET)
-
 #############################################################
 #
 # Toplevel Makefile options