boot/uboot: remove deprecated network settings option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 2 Jun 2015 17:52:12 +0000 (14:52 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Jun 2015 20:57:16 +0000 (22:57 +0200)
It's been deprecated since the 2014.05 release, so a year has passed.
Add legacy info as well to raise a warning when it's used.

[Peter: Remove entire config.h fixup handling]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
boot/uboot/Config.in
boot/uboot/uboot.mk

index 44de941f8e43314602a288ff765cda846961af7b..9b9fff021e506adfa594f15efcd8d9265b1aa058 100644 (file)
@@ -104,6 +104,15 @@ comment "build, or run, in unpredictable ways.               "
 comment "----------------------------------------------------"
 endif
 
+###############################################################################
+comment "Legacy options removed in 2015.08"
+
+config BR2_TARGET_UBOOT_NETWORK
+       bool "U-Boot custom network settings removed"
+       select BR2_LEGACY
+       help
+         U-Boot's custom network settings options have been removed.
+
 ###############################################################################
 comment "Legacy options removed in 2015.05"
 
index 4f014995cddfe3a177f86f25611d4fb6651f8c68..e884cc0163e0ce0dd93937c4a1c0092676d74c66 100644 (file)
@@ -192,52 +192,6 @@ config BR2_TARGET_UBOOT_OMAP_IFT_CONFIG
 
 endif
 
-menuconfig BR2_TARGET_UBOOT_NETWORK
-       bool "Custom Network Settings"
-       depends on BR2_DEPRECATED_SINCE_2014_05
-       help
-         Custom network settings for U-boot
-
-if BR2_TARGET_UBOOT_NETWORK
-
-config BR2_TARGET_UBOOT_SERVERIP
-       string "server ip"
-       default "10.175.196.221"
-       help
-         TFTP server ip address
-
-config BR2_TARGET_UBOOT_IPADDR
-       string "ip address"
-       default "10.175.196.18"
-       help
-         Target ip address
-
-config BR2_TARGET_UBOOT_GATEWAY
-       string "gateway ip"
-       default "10.175.196.1"
-       help
-         Gateway ip address
-
-config BR2_TARGET_UBOOT_NETMASK
-       string "netmask"
-       default "255.255.255.0"
-       help
-         Network Mask
-
-config BR2_TARGET_UBOOT_ETHADDR
-       string "ethernet address"
-       default "04:25:fe:ed:00:18"
-       help
-         Target MAC address for the ethernet interface.
-         This should be changed for production units
-
-config BR2_TARGET_UBOOT_ETH1ADDR
-       string "ethernet 2 address"
-       help
-         Target MAC address for the second ethernet interface.
-
-endif # BR2_TARGET_UBOOT_NETWORK
-
 config BR2_TARGET_UBOOT_SPL
        bool "Install U-Boot SPL binary image"
        depends on !BR2_TARGET_XLOADER
index 410d8d8a63ad8305c42f810522320722b374316d..8c10c6123ac2a40ed2ef8487b70d20d0364a9ea2 100644 (file)
@@ -125,19 +125,6 @@ define UBOOT_CONFIGURE_CMDS
        $(TARGET_CONFIGURE_OPTS)        \
                $(MAKE) -C $(@D) $(UBOOT_MAKE_OPTS)             \
                $(UBOOT_BOARD_NAME)_config
-       @echo >> $(@D)/include/config.h
-       @echo "/* Add a wrapper around the values Buildroot sets. */" >> $(@D)/include/config.h
-       @echo "#ifndef __BR2_ADDED_CONFIG_H" >> $(@D)/include/config.h
-       @echo "#define __BR2_ADDED_CONFIG_H" >> $(@D)/include/config.h
-       $(call insert_define,DATE,$(DATE))
-       $(call insert_define,CONFIG_LOAD_SCRIPTS,1)
-       $(call insert_define,CONFIG_IPADDR,$(BR2_TARGET_UBOOT_IPADDR))
-       $(call insert_define,CONFIG_GATEWAYIP,$(BR2_TARGET_UBOOT_GATEWAY))
-       $(call insert_define,CONFIG_NETMASK,$(BR2_TARGET_UBOOT_NETMASK))
-       $(call insert_define,CONFIG_SERVERIP,$(BR2_TARGET_UBOOT_SERVERIP))
-       $(call insert_define,CONFIG_ETHADDR,$(BR2_TARGET_UBOOT_ETHADDR))
-       $(call insert_define,CONFIG_ETH1ADDR,$(BR2_TARGET_UBOOT_ETH1ADDR))
-       @echo "#endif /* __BR2_ADDED_CONFIG_H */" >> $(@D)/include/config.h
 endef
 
 define UBOOT_BUILD_CMDS