package/netsurf: renumber patches
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 1 Dec 2020 22:12:59 +0000 (23:12 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 1 Dec 2020 22:31:36 +0000 (23:31 +0100)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/netsurf/0002-do-not-cross-compile-nsgenbind.patch [new file with mode: 0644]
package/netsurf/0003-do-not-cross-compile-nsgenbind.patch [deleted file]
package/netsurf/0003-fix-compilation-without-curl.patch [new file with mode: 0644]
package/netsurf/0004-fix-compilation-without-curl.patch [deleted file]

diff --git a/package/netsurf/0002-do-not-cross-compile-nsgenbind.patch b/package/netsurf/0002-do-not-cross-compile-nsgenbind.patch
new file mode 100644 (file)
index 0000000..2d46375
--- /dev/null
@@ -0,0 +1,30 @@
+From 2419ad79b25fcc1746178aba609fddbb0aa8c9e0 Mon Sep 17 00:00:00 2001
+From: Francois Perrad <francois.perrad@gadz.org>
+Date: Sat, 1 Dec 2018 16:10:13 +0100
+Subject: [PATCH] build nsgenbind for the build machine
+
+The nsgenbind tool is meant to be executed on the build machine during
+the build, so it should not be built with the cross-compiler, but with
+the native compiler.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f279f01..5698c87 100644
+--- a/Makefile
++++ b/Makefile
+@@ -110,7 +110,7 @@ endef
+ # prefixed install macro for each host sub target
+ define do_build_prefix_install
+-      $(MAKE) install --directory=$1 HOST=$(BUILD) PREFIX=$(TMP_PREFIX) Q=$(Q) DESTDIR=
++      $(MAKE) install --directory=$1 HOST=$(BUILD) CC=$(BUILD_CC) PREFIX=$(TMP_PREFIX) Q=$(Q) DESTDIR=
+ endef
+-- 
+2.17.1
+
diff --git a/package/netsurf/0003-do-not-cross-compile-nsgenbind.patch b/package/netsurf/0003-do-not-cross-compile-nsgenbind.patch
deleted file mode 100644 (file)
index 2d46375..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 2419ad79b25fcc1746178aba609fddbb0aa8c9e0 Mon Sep 17 00:00:00 2001
-From: Francois Perrad <francois.perrad@gadz.org>
-Date: Sat, 1 Dec 2018 16:10:13 +0100
-Subject: [PATCH] build nsgenbind for the build machine
-
-The nsgenbind tool is meant to be executed on the build machine during
-the build, so it should not be built with the cross-compiler, but with
-the native compiler.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index f279f01..5698c87 100644
---- a/Makefile
-+++ b/Makefile
-@@ -110,7 +110,7 @@ endef
- # prefixed install macro for each host sub target
- define do_build_prefix_install
--      $(MAKE) install --directory=$1 HOST=$(BUILD) PREFIX=$(TMP_PREFIX) Q=$(Q) DESTDIR=
-+      $(MAKE) install --directory=$1 HOST=$(BUILD) CC=$(BUILD_CC) PREFIX=$(TMP_PREFIX) Q=$(Q) DESTDIR=
- endef
--- 
-2.17.1
-
diff --git a/package/netsurf/0003-fix-compilation-without-curl.patch b/package/netsurf/0003-fix-compilation-without-curl.patch
new file mode 100644 (file)
index 0000000..2300ae5
--- /dev/null
@@ -0,0 +1,27 @@
+From 7d7c59dbfc92fcbcd0eac2c84e0fb98662c4bd71 Mon Sep 17 00:00:00 2001
+From: Francois Perrad <francois.perrad@gadz.org>
+Date: Sat, 8 Dec 2018 09:43:40 +0100
+Subject: [PATCH] fix compilation without curl
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+---
+ netsurf/content/fetch.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/netsurf/content/fetch.c b/netsurf/content/fetch.c
+index 7665029..0f41c49 100644
+--- a/netsurf/content/fetch.c
++++ b/netsurf/content/fetch.c
+@@ -54,7 +54,9 @@
+ #include "content/fetchers.h"
+ #include "content/fetchers/resource.h"
+ #include "content/fetchers/about.h"
++#ifdef WITH_CURL
+ #include "content/fetchers/curl.h"
++#endif
+ #include "content/fetchers/data.h"
+ #include "content/fetchers/file.h"
+ #include "javascript/fetcher.h"
+-- 
+2.17.1
+
diff --git a/package/netsurf/0004-fix-compilation-without-curl.patch b/package/netsurf/0004-fix-compilation-without-curl.patch
deleted file mode 100644 (file)
index 2300ae5..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From 7d7c59dbfc92fcbcd0eac2c84e0fb98662c4bd71 Mon Sep 17 00:00:00 2001
-From: Francois Perrad <francois.perrad@gadz.org>
-Date: Sat, 8 Dec 2018 09:43:40 +0100
-Subject: [PATCH] fix compilation without curl
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
----
- netsurf/content/fetch.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/netsurf/content/fetch.c b/netsurf/content/fetch.c
-index 7665029..0f41c49 100644
---- a/netsurf/content/fetch.c
-+++ b/netsurf/content/fetch.c
-@@ -54,7 +54,9 @@
- #include "content/fetchers.h"
- #include "content/fetchers/resource.h"
- #include "content/fetchers/about.h"
-+#ifdef WITH_CURL
- #include "content/fetchers/curl.h"
-+#endif
- #include "content/fetchers/data.h"
- #include "content/fetchers/file.h"
- #include "javascript/fetcher.h"
--- 
-2.17.1
-