package/asn1c: new host package
authorSergio Prado <sergio.prado@e-labworks.com>
Fri, 10 Jan 2020 21:14:20 +0000 (18:14 -0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 14 Sep 2020 20:16:23 +0000 (22:16 +0200)
The asn1c is a free, open source compiler of ASN.1 specifications into C
source code.

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
Reviewed-by: Heiko Thiery <heiko.thiery@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in.host
package/asn1c/Config.in.host [new file with mode: 0644]
package/asn1c/asn1c.hash [new file with mode: 0644]
package/asn1c/asn1c.mk [new file with mode: 0644]

index 884c79cfdf1428c8275ea804384cae7ee48d7b7d..f754a6f34185a5cea0ad15048badde9a3e127e27 100644 (file)
@@ -2384,6 +2384,7 @@ N:        Sergio Prado <sergio.prado@e-labworks.com>
 F:     board/toradex/apalis-imx6/
 F:     configs/toradex_apalis_imx6_defconfig
 F:     package/aoetools/
+F:     package/asn1c/
 F:     package/azure-iot-sdk-c/
 F:     package/curlpp/
 F:     package/daq/
index 097e2fb47d140eadadb51ac00de25e57466e7111..243da8969f87c7b4944c33818606c111fb0b257c 100644 (file)
@@ -2,6 +2,7 @@ menu "Host utilities"
 
        source "package/aespipe/Config.in.host"
        source "package/android-tools/Config.in.host"
+       source "package/asn1c/Config.in.host"
        source "package/babeltrace2/Config.in.host"
        source "package/btrfs-progs/Config.in.host"
        source "package/cbootimage/Config.in.host"
diff --git a/package/asn1c/Config.in.host b/package/asn1c/Config.in.host
new file mode 100644 (file)
index 0000000..951f5f6
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_HOST_ASN1C
+       bool "host asn1c"
+       help
+         ASN.1 stands for Abstract Syntax Notation One and allows
+         to describe complex data structures independently of any
+         particular programming language.
+
+         The asn1c is a free, open source compiler of ASN.1
+         specifications into C source code.
+
+         http://lionet.info/asn1c
diff --git a/package/asn1c/asn1c.hash b/package/asn1c/asn1c.hash
new file mode 100644 (file)
index 0000000..abc4d77
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally computed:
+sha256  8007440b647ef2dd9fb73d931c33ac11764e6afb2437dbe638bb4e5fc82386b9  asn1c-0.9.28.tar.gz
+
+# Hash for license files:
+sha256  bcc636802a52ace2255212be15fb707084af87061b5cfd37eb84dcf6a02cc48b  LICENSE
diff --git a/package/asn1c/asn1c.mk b/package/asn1c/asn1c.mk
new file mode 100644 (file)
index 0000000..314462a
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# asn1c
+#
+################################################################################
+
+ASN1C_VERSION = 0.9.28
+ASN1C_SITE = https://github.com/vlm/asn1c/releases/download/v$(ASN1C_VERSION)
+ASN1C_LICENSE = BSD-2-Clause
+ASN1C_LICENSE_FILES = LICENSE
+
+$(eval $(host-autotools-package))