package/linknx: host-pkgconf is mandatory
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 27 Feb 2020 23:15:27 +0000 (00:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 28 Feb 2020 06:35:45 +0000 (07:35 +0100)
host-pkgconf is a mandatory dependency, this will fix per-package build

Fixes:
 - http://autobuild.buildroot.org/results/cfda0ce53165bb22b691b5b6510f0ab096a41e17

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/linknx/linknx.mk

index 15d4b5a1097e3b6d3df587fef03948c44f704cfe..c75f0655d66993224ebe0a868b311dc1ccadc39e 100644 (file)
@@ -17,7 +17,9 @@ LINKNX_CONF_OPTS = \
        --with-pth=$(STAGING_DIR)/usr \
        --disable-smtp
 
-LINKNX_DEPENDENCIES = libpthsem \
+LINKNX_DEPENDENCIES = \
+       host-pkgconf \
+       libpthsem \
        $(if $(BR2_PACKAGE_ARGP_STANDALONE),argp-standalone) \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 
@@ -30,7 +32,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_LOG4CPP),y)
 LINKNX_CONF_OPTS += --with-log4cpp
-LINKNX_DEPENDENCIES += host-pkgconf log4cpp
+LINKNX_DEPENDENCIES += log4cpp
 else
 LINKNX_CONF_OPTS += --without-log4cpp
 endif