package/capnproto: bump version to 0.8.0
authorKoen Martens <gmc@sonologic.nl>
Sat, 16 May 2020 07:53:13 +0000 (09:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 8 Aug 2020 21:24:51 +0000 (23:24 +0200)
The new version requires an extra features in the toolchain and won't
build with a specific gcc bug, therefore two new toolchain options are
added as dependencies:

* !BR2_TOOLCHAIN_HAS_GCC_BUG_64735
* BR2_TOOLCHAIN_HAS_UCONTEXT

Signed-off-by: Koen Martens <gmc@sonologic.nl>
Reviewed-by: Joel Carlson <JoelsonCarl@gmail.com>
Tested-by: Joel Carlson <JoelsonCarl@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/c-capnproto/Config.in
package/capnproto/Config.in
package/capnproto/capnproto.hash
package/capnproto/capnproto.mk

index d1f3236af86185fe5ca1810cb5b473eb9767f382..41a59d7a22e19587f266a49d836d666ae7d12d6d 100644 (file)
@@ -6,6 +6,8 @@ config BR2_PACKAGE_C_CAPNPROTO
        depends on BR2_INSTALL_LIBSTDCPP # capnproto
        depends on BR2_TOOLCHAIN_HAS_THREADS # capnproto
        depends on BR2_TOOLCHAIN_HAS_ATOMIC # capnproto
+       depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735 # capnproto
+       depends on BR2_TOOLCHAIN_HAS_UCONTEXT # capnproto
        select BR2_PACKAGE_CAPNPROTO
        help
          A C plugin for Cap'n Proto. Generates the code generator
@@ -14,10 +16,12 @@ config BR2_PACKAGE_C_CAPNPROTO
 
          https://github.com/opensourcerouting/c-capnproto
 
-comment "c-capnproto needs host and target gcc >= 5 w/ C++14, threads, atomic"
+comment "c-capnproto needs host and target gcc >= 5 w/ C++14, threads, atomic, ucontext and not gcc bug 64735"
        depends on BR2_USE_MMU
        depends on!BR2_HOST_GCC_AT_LEAST_5 || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_5 || \
                !BR2_INSTALL_LIBSTDCPP || \
                !BR2_TOOLCHAIN_HAS_THREADS || \
-               !BR2_TOOLCHAIN_HAS_ATOMIC
+               !BR2_TOOLCHAIN_HAS_ATOMIC || \
+               BR2_TOOLCHAIN_HAS_GCC_BUG_64735 || \
+               !BR2_TOOLCHAIN_HAS_UCONTEXT
index cd9cb647af69c29cb0b3dbcd5e508359061e4adf..943ba9de2946975f868b333c18a2758dad862622 100644 (file)
@@ -6,6 +6,8 @@ config BR2_PACKAGE_CAPNPROTO
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_TOOLCHAIN_HAS_ATOMIC
+       depends on !BR2_TOOLCHAIN_HAS_GCC_BUG_64735
+       depends on BR2_TOOLCHAIN_HAS_UCONTEXT
        help
          Cap'n Proto is an insanely fast data interchange format
          and capability-based RPC system. Think JSON, except
@@ -15,10 +17,12 @@ config BR2_PACKAGE_CAPNPROTO
 
          https://capnproto.org/index.html
 
-comment "capnproto needs host and target gcc >= 5 w/ C++14, threads, atomic"
+comment "capnproto needs host and target gcc >= 5 w/ C++14, threads, atomic, ucontext and not gcc bug 64735"
        depends on BR2_USE_MMU
        depends on !BR2_HOST_GCC_AT_LEAST_5 || \
                !BR2_TOOLCHAIN_GCC_AT_LEAST_5 || \
                !BR2_INSTALL_LIBSTDCPP || \
                !BR2_TOOLCHAIN_HAS_THREADS || \
-               !BR2_TOOLCHAIN_HAS_ATOMIC
+               !BR2_TOOLCHAIN_HAS_ATOMIC || \
+               BR2_TOOLCHAIN_HAS_GCC_BUG_64735 || \
+               !BR2_TOOLCHAIN_HAS_UCONTEXT
index 98467f8634d4d308e0d0708cb1693b2afa0477fc..d4500e0aad649570868888a180bc1ebd42bf027d 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 76c7114a3d142ad08b7208b3964a26e72a6320ee81331d3f0b87569fc9c47a28  capnproto-0.7.0.tar.gz
+sha256 6d8b43a7ec2a764b4dfe4139a7cdd070ad9057f106898050d9f4db3754b98820  capnproto-0.8.0.tar.gz
 sha256 9564998c8d7f270a61a8b89869a8d17a9d5e3783b64027788b5e339ec8479e10  LICENSE
index 34fb8859147fd15ddd1cdcc679f8f215a8a280c9..e9e89dff07d6e2b8bf2bdc78aa21464b432a8038 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-CAPNPROTO_VERSION = 0.7.0
+CAPNPROTO_VERSION = 0.8.0
 CAPNPROTO_SITE = $(call github,capnproto,capnproto,v$(CAPNPROTO_VERSION))
 CAPNPROTO_LICENSE = MIT
 CAPNPROTO_LICENSE_FILES = LICENSE