leveldb: install memenv static library and header
authorGaël PORTAY <gael.portay@collabora.com>
Wed, 2 Jan 2019 20:56:28 +0000 (15:56 -0500)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Thu, 7 Mar 2019 21:45:48 +0000 (22:45 +0100)
The project builds a tiny static library that consists of a single
symbol which creates an in-memory LevelDB database.

That library is not installed by default and may be used by other
projects.

This commit installs in the staging directory the libmemenv.a static
library and the memenv.h header file.

Signed-off-by: Gaël PORTAY <gael.portay@collabora.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/leveldb/leveldb.mk

index af9e8798282e221cac7a96dd395ce03deeb47fb0..6078cd496c3d9aec0b4d50f59bd83d832febdd62 100644 (file)
@@ -25,6 +25,8 @@ define LEVELDB_INSTALL_STAGING_CMDS
        $(TARGET_MAKE_ENV) $(MAKE1) \
                INSTALL_ROOT=$(STAGING_DIR) INSTALL_PREFIX=/usr \
                $(LEVELDB_MAKE_ARGS) -C $(@D) install
+       $(INSTALL) -D -m 0644 $(@D)/out-static/libmemenv.a $(STAGING_DIR)/usr/lib/libmemenv.a
+       $(INSTALL) -D -m 0644 $(@D)/helpers/memenv/memenv.h $(STAGING_DIR)/usr/include/helpers/memenv/memenv.h
 endef
 
 define LEVELDB_INSTALL_TARGET_CMDS