gvfs: add optional libusb support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 19 Oct 2018 20:13:10 +0000 (22:13 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 20 Oct 2018 16:03:08 +0000 (18:03 +0200)
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gvfs/gvfs.mk

index 19747b4cb00e357381859bbc88f8ea9b1aa9abf8..b62923a500b373c5e998565d4b9b4fde82e822b9 100644 (file)
@@ -99,6 +99,13 @@ else
 GVFS_CONF_OPTS += --disable-http
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUSB),y)
+GVFS_DEPENDENCIES += libusb
+GVFS_CONF_OPTS += --enable-libusb
+else
+GVFS_CONF_OPTS += --disable-libusb
+endif
+
 ifeq ($(BR2_PACKAGE_SAMBA4),y)
 GVFS_DEPENDENCIES += samba4
 GVFS_CONF_OPTS += \