package/opencv3: add webp support
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 18 Oct 2020 15:02:11 +0000 (17:02 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 18 Oct 2020 19:44:08 +0000 (21:44 +0200)
webp support is available since version 3.0.0 and
https://github.com/opencv/opencv/commit/500b7318beee639d8c341e9ea63ac7610ca225f4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/opencv3/Config.in
package/opencv3/opencv3.mk

index 22dcb67f3a5e4159bb945add5aecc6d5bb7ff3cc..1fda3cf089ddaf1628a3c7df6c72568d25d9eb51 100644 (file)
@@ -313,6 +313,14 @@ config BR2_PACKAGE_OPENCV3_WITH_V4L
          If the package libv4l is enabled, its support is
          automatically enabled.
 
+config BR2_PACKAGE_OPENCV3_WITH_WEBP
+       bool "webp support"
+       select BR2_PACKAGE_WEBP
+       help
+         Enable WebP support.
+
+         Use shared libwebp from the target system.
+
 comment "Install options"
 
 config BR2_PACKAGE_OPENCV3_INSTALL_DATA
index 648cc66af370e66fa4cabdadedce446fb32e4073..12d2e3c00ca19352838c3cffdbfe9be1eb535bbb 100644 (file)
@@ -223,7 +223,6 @@ OPENCV3_CONF_OPTS += \
        -DWITH_VA=OFF \
        -DWITH_VA_INTEL=OFF \
        -DWITH_VTK=OFF \
-       -DWITH_WEBP=OFF \
        -DWITH_XINE=OFF
 
 OPENCV3_DEPENDENCIES += host-pkgconf zlib
@@ -318,6 +317,13 @@ else
 OPENCV3_CONF_OPTS += -DWITH_V4L=OFF -DWITH_LIBV4L=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_OPENCV3_WITH_WEBP),y)
+OPENCV3_CONF_OPTS += -DWITH_WEBP=ON
+OPENCV3_DEPENDENCIES += webp
+else
+OPENCV3_CONF_OPTS += -DWITH_WEBP=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_OPENCV3_LIB_PYTHON),y)
 OPENCV3_CONF_OPTS += \
        -DBUILD_opencv_python2=OFF \