package/libdrm: add optional cunit dependency
authorMatt Weber <matthew.weber@rockwellcollins.com>
Thu, 1 Nov 2018 18:58:16 +0000 (13:58 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 29 Nov 2018 21:50:47 +0000 (22:50 +0100)
Previously the option to install tests would result in the test cases
that don't have a cunit dependency, to build and be installed.

This patch adds an optional dependency on cunit so that all test cases
can be built and installed to target.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
[Thomas: keep as an optional dependency, as cunit is only useful for
additional tests specific to the amdgpu backend]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libdrm/libdrm.mk

index 18ef9cdd2e7e674dad589cd11da8bc8c8fa4e1d2..06efa2019560c58577a41dde1a9a5eaa90e9a55e 100644 (file)
@@ -115,6 +115,9 @@ endif
 
 ifeq ($(BR2_PACKAGE_LIBDRM_INSTALL_TESTS),y)
 LIBDRM_CONF_OPTS += --enable-install-test-programs
+ifeq ($(BR2_PACKAGE_CUNIT),y)
+LIBDRM_DEPENDENCIES += cunit
+endif
 endif
 
 $(eval $(autotools-package))