perf: add kernel version checks
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 6 Jan 2013 05:22:47 +0000 (05:22 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 7 Jan 2013 20:40:20 +0000 (21:40 +0100)
perf is only available since kernel 2.6.31, so if we can't find
tools/perf/Makefile, error out and tell the user about this.

perf without libelf can only be built since kernel 3.7, so error out
and tell the user about this if he's trying to build perf from a < 3.7
kernel without libelf.

Unfortunately, those tests can only be build-time checks as we either
need to know the real kernel version (i.e, using LINUX_VERSION would
not be correct as it can be a Git commit ID, or Git tag), or have
access to the kernel sources themselves. So we can't prevent those
invalid situations at the configuration, we can only nicely tell the
user at build time.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/perf/perf.mk

index eed30a289c1464cf46661a58d0f133b14b3d5d8b..4356f5db5d6862a9d4038b48347b78d9e31c59dd 100644 (file)
@@ -28,6 +28,18 @@ else
 endif
 
 define PERF_BUILD_CMDS
+       $(Q)if test ! -f $(LINUX_DIR)/tools/perf/Makefile ; then \
+               echo "Your kernel version is too old and does not have the perf tool." ; \
+               echo "At least kernel 2.6.31 must be used." ; \
+               exit 1 ; \
+       fi
+       $(Q)if test "$(BR2_PACKAGE_ELFUTILS)" = "" ; then \
+               if ! grep -q NO_LIBELF $(LINUX_DIR)/tools/perf/Makefile ; then \
+                       echo "The perf tool in your kernel cannot be built without libelf." ; \
+                       echo "Either upgrade your kernel to >= 3.7, or enable the elfutils package." ; \
+                       exit 1 ; \
+               fi \
+       fi
        $(MAKE) -C $(LINUX_DIR)/tools/perf \
                $(PERF_MAKE_FLAGS) O=$(@D)
 endef