package/feh: Fix build issue with some older cross-compilers
authorPetr Vorel <petr.vorel@gmail.com>
Thu, 16 Nov 2017 10:04:57 +0000 (11:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Nov 2017 21:42:40 +0000 (22:42 +0100)
by adding -std=gnu99 to CFLAGS.

Fixes:
http://autobuild.buildroot.net/results/392b58cca2671e206c85a530221ce7b2d42f31fb/
http://autobuild.buildroot.net/results/94527fcd70fa85298c366537013c939534beead0/
http://autobuild.buildroot.net/results/bf31199cdaa18971a9b599c26fbefac73b2d6f30/
http://autobuild.buildroot.net/results/5b65c305b50664e02d5f8022278055c80739342d/
http://autobuild.buildroot.net/results/ed3b9fb8d09cd677af4b8825566877c552926ae5/

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/feh/feh.mk

index 3f4c410440d6fccf746a86e5c42cb9e409f3876a..7211dc7bddf2e955b7041c2d83a6b80c45ac3e2d 100644 (file)
@@ -12,8 +12,8 @@ FEH_LICENSE = MIT
 FEH_LICENSE_FILES = COPYING
 
 define FEH_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
-               -C $(@D) all
+       $(TARGET_MAKE_ENV) CFLAGS="$(TARGET_CFLAGS) -std=gnu99" $(MAKE1) \
+               CC="$(TARGET_CC) $(TARGET_LDFLAGS)" -C $(@D) all
 endef
 
 define FEH_INSTALL_TARGET_CMDS