qt5: add macro to fixup Qt5 .la and .prl files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 7 Mar 2013 10:18:37 +0000 (10:18 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Mar 2013 21:36:59 +0000 (22:36 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt5/qt5.mk

index 8b1a7ed3ea94ff601d45503e7ef194a41a80bb0d..f22050876c8749955dc42c67ebd59352f06c499e 100644 (file)
@@ -1 +1,11 @@
 include package/qt5/*/*.mk
+
+define QT5_LA_PRL_FILES_FIXUP
+       for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.la"); do \
+               $(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$i; \
+               $(SED) "/^dependency_libs=/s%-L/usr/lib %%g" $$i ; \
+       done
+       for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.prl"); do \
+               $(SED) "s%-L/usr/lib%%" $$i; \
+       done
+endef